Bug 342871 - multiarch conflicts in pigment
Summary: multiarch conflicts in pigment
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pigment
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthias Saou
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-19 21:53 UTC by Bill Nottingham
Modified: 2014-03-17 03:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-22 09:30:22 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2007-10-19 21:53:44 UTC
pigment (or one of its subpacakges) has multiarch conflicts when installed for both i386 and x86_64 in the Fedora development tree. For help in resolving them, see http://fedoraproject.org/wiki/PackagingDrafts/MultilibTricks. 

  file /usr/lib/python2.5/site-packages/pgm/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pgm/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pgm/keysyms.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pgm/keysyms.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/drawable.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/drawable.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/group.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/group.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/image.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/image.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/text.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/graph/text.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/controller.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/controller.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/implicit.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/implicit.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/keyframe.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/keyframe.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/modifier.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/timing/modifier.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/classinit.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/classinit.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/maths.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/utils/maths.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/__init__.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/__init__.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/console.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/console.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/curved_list.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/curved_list.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/dock.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/dock.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/grid_view.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/grid_view.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/image_list.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/image_list.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/list.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/list.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/player_osd.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/player_osd.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/progressbar_osd.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/progressbar_osd.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/ring_list.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/ring_list.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/scrollbar.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/scrollbar.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/slideshow.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/slideshow.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/text_list.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/text_list.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/top_level_menu.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/top_level_menu.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/volume_osd.pyc from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8
  file /usr/lib/python2.5/site-packages/pypgmtools/widgets/volume_osd.pyo from install of pigment-0.3.2-1.fc8 conflicts with file from package pigment-0.3.2-1.fc8

(Note that this is an automated bug filing.)
It would be nice to have these bugs fixed by the beta of Fedora 9.

Comment 1 Bug Zapper 2008-05-14 03:37:13 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Matthias Saou 2008-12-22 09:30:22 UTC
Most of this has stopped being an issue ever since "pigment-python" became its own source package. I've now disabled gtk-doc in 0.3.13-2 to fix the rest, as I've found no easy solution to have all of the generated html anchors have the same ids across rebuilds and saw that disabling it altogether had been done in many other Fedora packages.


Note You need to log in before you can comment on or make changes to this bug.