Bug 34294 - openssh-2.5.2p2-1.7; failed dependency on libcrypto
Summary: openssh-2.5.2p2-1.7; failed dependency on libcrypto
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-01 16:47 UTC by sean
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-01 16:47:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sean 2001-04-01 16:47:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3 i686)


When I rpm -Fvh openssh2.5.2p2-1.7, I get failed dependencies because
libcrypto.so.0 is needed.

openssl-9.6-2 is installed. libcrypto.so.0 is in /usr/lib.  I don't see an
update for openssl.



Reproducible: Always
Steps to Reproduce:
1.pm -Fvh openssh*
2.
3.

Comment 1 Bill Nottingham 2001-04-02 03:14:27 UTC
openssl-0.9.6 doesn't provide libcrypto.so.0; it provides libcrypto.so.1.

You apparently aren't using the openssl for 7.0 (0.9.5a); if you have the openssl
from the beta installed, you also need the openssl095a package from the beta.

Comment 2 sean 2001-04-06 21:10:44 UTC
FWIW, I got openssl-9.6-3. openssh then installed. /usr/lib/libcrypto.so.1 is
there. I assume 9.6-3 put it there. In any event, I assume we don't need
openssl95a.

thanks for your help


Note You need to log in before you can comment on or make changes to this bug.