This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 34317 - lilo.conf updating doesn't quite work right
lilo.conf updating doesn't quite work right
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-01 22:17 EDT by Jeremy Katz
Modified: 2015-01-07 18:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 11:21:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-04-01 22:17:31 EDT
With up2date-2.4.6-1, the lilo.conf updating doesn't seem to be quite
correct since it always tries to add an initrd to the lilo.conf even if one
isn't needed (and thus isn't created).  Thus the test lilo run fails and
you have to manually do the lilo.conf updating for the kernel package update.
Comment 1 Glen Foster 2001-04-02 09:51:31 EDT
This defect considered MUST-FIX for Florence Gold
Comment 2 Adrian Likins 2001-04-02 10:17:37 EDT
can you attach a copy of the original and the created lilo.conf?

up2date should always run `mkinitrd`, but with the "--if-needed" flag.

Comment 3 Adrian Likins 2001-04-02 11:14:24 EDT
looks like I was assuming that `mkinitrd` returned a different error
code when it existed because an initrd wasnt needed, and when it
was need and created it successfully. Looking though the mkinitrd
script would seem to indicate this never should of worked, but seemed
to work in practice (the error code was determined empirically, apparently
incorrectly...).

Now the code checks for existense of the initrd after calling `mkinitrd`
to see if it did infact create one, since this seems to be the only
way to tell. Should be a fix in cvs for testing now...
Comment 4 Preston Brown 2001-04-02 15:46:15 EDT
tested, fixed in 2.4.7.

Note You need to log in before you can comment on or make changes to this bug.