Bug 34320 - gnorpm-0.95.1 fails compile on SPARC
gnorpm-0.95.1 fails compile on SPARC
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
6.2
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
none
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-01 23:23 EDT by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-01 23:23:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-01 23:23:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.51 [en] (X11; I; Linux 2.2.17-14 sparc)


Upgraded to RPM version 4.0.2.
***No upgraded gnorpm binary package were supplied for sparc on 
RedHat updates site***
Attempt to compile from source rpm failed.

Reproducible: Always
Steps to Reproduce:
1.untar source from source rpm
2. ./configure
3.make
	

Actual Results:  Compile dies at:

gcc -DHAVE_CONFIG_H -I. -I. -I. -I/usr/include -DNEED_GNOMESUPPORT_H
-I/usr/lib/gnome-libs/include -I/usr/lib/glib/include -I/usr/X11R6/include
-I/usr/include/rpm           
-DGNOMELOCALEDIR=\""/usr/local/share/locale"\" 	  
-DG_LOG_DOMAIN=\"GnoRPM\"    -g -O2 -Wall -Wunused  -c install.c
install.c: In function `printProblems':
install.c:457: incompatible type for argument 1 of `rpmProblemString'
install.c: In function `do_install':
install.c:595: warning: passing arg 2 of `rpmRunTransactions' from
incompatible pointer type
install.c:603: warning: passing arg 2 of `rpmRunTransactions' from
incompatible pointer type
make[2]: *** [install.o] Error 1
make[2]: Leaving directory `/usr/src/redhat/SOURCES/gnorpm-0.95.1'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/SOURCES/gnorpm-0.95.1'
make: *** [all-recursive-am] Error 2



Expected Results:  It should have compiled.

Compile try was done with SPARC LX machine with RH 6.2 as updated
with all available packages on the updates ftp site.

A new RPM package should not have been released for the SPRARC architecture
until packages for all other programs it would break were also available.

Also various website links to various packages fail due to what appears to
be a recent RedHat directory restructuring.
Comment 1 Jeff Johnson 2001-04-02 09:42:15 EDT
You need to appy the patches that are in the src.rpm as well.
The problem you have pointed out is fixed there.

Note You need to log in before you can comment on or make changes to this bug.