Bug 3435 - Config files not marked as config files in inn-2.2-*
Config files not marked as config files in inn-2.2-*
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: inn (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-13 15:56 EDT by Edward Kuns
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-13 16:19:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 1999-06-13 15:56:35 EDT
When I installed 6.0 all my old inn config files got
completely blown away because those files were NOT marked as
config files in the newer inn rpm file.  This means my
active file, history file ... basically everything in
/var/lib/news ... got blown away with no "rpmsave" file.

If you "rpm -qcp inn-1*" on an older (i.e., Red Hat 5.2) inn
rpm file, you will see a bunch of /var/lib/news config
files.  Doing this command on any 6.0 inn rpm shows *no*
files in /var/lib/news.

Upgrading inn (and upgrading Red Hat from 5.2 to 6.0) SHOULD
NOT blow away one's existing active file!!!
Comment 1 Jeff Johnson 1999-06-13 16:19:59 EDT
Fixed (by marking /var/lib/news/* as "%config(noreplace)") in
inn-2.2-13. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.