Bug 34359 - (IDE)cdrom drive cannot be mounted
(IDE)cdrom drive cannot be mounted
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-02 12:18 EDT by Geert Dobbels
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Geert Dobbels 2001-04-02 12:18:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [es] (WinNT; I)


After successfully installing wolverine from the cdrom drive and rebooting the system, this same cdrom drive cannot be mounted.

Reproducible: Always
Steps to Reproduce:
1.Install Wolverine from cdrom
2.reboot system
3.try to access cdrom
	

Actual Results:  after rebooting, and trying to mount the cdrom, an error message, saying that no filesystem type is given appears.
The filesystem defined in /etc/fstab for the cdrom is "auto".
After changing this from "auto" to "iso9660", another error message appears, saying that the device could not be accessed and suggesting that 
it maybe is the cdrom drive that should be accessed through the "ide-scsi" module.

The cdrom drive in question is a plain ATAPI 50x cdrom.  It works fine during the install and on other OSes and also had no problems on 
RedHat 6.2

Expected Results:  Drive should be accessible

As additional information, the contents of several files in the /proc directory and others are included:

------------/proc/cpuinfo--------------------------

processor   : 0
vendor_id   : AuthenticAMD
cpu family  : 5
model       : 8
model name  : AMD-K6(tm) 3D processor
stepping    : 12
cpu MHz     : 451.024
cache size  : 64 KB
fdiv_bug    : no
hlt_bug     : no
f00f_bug    : no
coma_bug    : no
fpu     : yes
fpu_exception   : yes
cpuid level : 1
wp      : yes
flags       : fpu vme de pse tsc msr mce cx8 pge mmx syscall 3dnow k6_mtrr
bogomips    : 897.84

---------------------------/proc/devices---------------------------------------

Character devices:

  1 mem

  2 pty

  3 ttyp

  4 ttyS

  5 cua

  6 lp

  7 vcs

 10 misc

 14 sound

 29 fb

 36 netlink

109 lvm

128 ptm

136 pts

162 raw

180 usb



Block devices:

  1 ramdisk

  2 fd

  3 ide0

  9 md

 22 ide1

 58 lvm

-----------------/proc/ioports------------------------------------------------------------

0000-001f : dma1

0020-003f : pic1

0040-005f : timer

0060-006f : keyboard

0070-007f : rtc

0080-008f : dma page reg

00a0-00bf : pic2

00c0-00df : dma2

00f0-00ff : fpu

0170-0177 : ide1

01f0-01f7 : ide0

0213-0213 : isapnp read

02f8-02ff : serial(auto)

0376-0376 : ide1

0378-037a : parport0

03c0-03df : vga+

03f0-03f5 : floppy

03f6-03f6 : ide0

03f7-03f7 : floppy DIR

03f8-03ff : serial(auto)

0778-077a : parport0

0a79-0a79 : isapnp write

0cf8-0cff : PCI conf1

f000-f0ff : Realtek Semiconductor Co., Ltd. RTL-8139

  f000-f0ff : eth0

f400-f40f : Acer Laboratories Inc. [ALi] M5229 IDE

  f400-f407 : ide0

  f408-f40f : ide1


--------------------------/etc/fstab---------------------------------

LABEL=/                 /                       ext2    defaults        1 1

LABEL=/home             /home                   ext2    defaults        1 2

/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0

LABEL=/usr              /usr                    ext2    defaults        1 2

none  /proc                   proc    defaults        0 0

none                    /dev/pts                devpts  gid=5,mode=620  0 0

/dev/hdc1               swap                    swap    defaults        0 0

/dev/cdrom              /mnt/cdrom              auto    noauto,owner,kudzu,ro 0 0
Comment 1 Geert Dobbels 2001-04-10 05:49:37 EDT
After 1 more unsuccessfull reinstall, the cdrom drive started working on the 3rd trial...... no explanation found.
Comment 2 Geert Dobbels 2001-04-12 10:22:07 EDT
Unfortunately, it only worked once......  after another reboot it could again
not be mounted any more.
New reinstallation of wolverine dit not help.  As a check, I reinstalled Linux
7.0 and there the cdrom worked without any problem........
Comment 3 Arjan van de Ven 2001-04-18 10:44:42 EDT
Could you try booting a recent kernel (2.4.2-0.1.40 or 2.4.2-2) and use
"ide=nodma" to see if that helps ?
(if so, please give the output of "cat /proc/ide/hdc/model" (1))


(1) change "hdc" to the appropriate device of your cdrom drive
Comment 4 Geert Dobbels 2001-05-07 10:50:35 EDT
Since I am not a Linux guru, and have no experience at loading this or that
specific kernel, I decided to give seawolf (redhat 7.1) a try, with the
following (dissapointing) results:
Booting from the CDROM, the typical textscreen appears where one has to choose
between new installation, upgrade, expert mode ..... choosing new installation,
the next screen appears with the pinguin and all the initialisation messages
(apparently without errors in them).  Then the user is asked for the
installation language, the keyboard type and if he installs from cdrom or from
harddisk.  After answering CDROM, I receive a message saying that the system
could not find a Red Hat Linux CDROM in my drive, and I cannot go on with the
installation.  To be sure that the data on my CD was downloaded correctly, I
repeated the download from another site, burned a new CD, but the result was the
same.
Comment 5 Arjan van de Ven 2001-05-07 16:58:15 EDT
Could you please type "linux ide=nodma" on the first syslinux prompt and
tell me if that helps ?
Comment 6 Geert Dobbels 2001-05-08 04:33:43 EDT
I'll try your suggestion as soon as I can, and tell you the results.

What I tried was switching off ide DMA in the Bios configuration, but this didn't help.

In the meantime, allthough the concerned CDrom drive works fine under windows (and worked fine under RedHat 6.2), I started to get suspicious about 
this drive.  After several unsuccessfull attempts to install Redhat 7.1 from it, I disconnected it from the PC and built in another CDrom drive which let me 
install 7.1 without any problem.  After installing 7.1, I again swapped the drives and build in the old one that gave me problems, and now I can startup 
Linux and access this CDrom drive without any problem !!!

(The concerned drive is "Afreey CD-2050R", an 50x atapi CDROM.)
Comment 7 Arjan van de Ven 2001-05-08 04:38:54 EDT
Most "bad" cdromdrives I've seen so far only misbehave under high load;
but you proved it is related to this one drive, which is a good thing.
Comment 8 G. Bersano 2001-05-09 09:15:19 EDT
Same problem here: ... the user is asked for the installation language, the
keyboard type and if he installs from cdrom or from harddisk.  After answering
CDROM, a message says that the system 
could not find a Red Hat Linux CDROM in the drive.
Test machines: COMPAQ PROSIGNIA with hdc Compaq CRD-8402B; COMPAQ ARMADA E500
with hdb CD-224E.
Tried with 'linux ide=nodma' too, same result.
Copied iso images on the hard disk and installation went smooth; after install
CD-ROM works flawlessly.
Comment 9 Bugzilla owner 2004-09-30 11:38:57 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.