Bug 34363 - Segmentation fault if krb5_init_context fails
Segmentation fault if krb5_init_context fails
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: pam_krb5 (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-02 12:42 EDT by Simon Wilkinson
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-02 13:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix this against 1.26 (1.91 KB, patch)
2001-04-02 13:00 EDT, Simon Wilkinson
no flags Details | Diff

  None (edit)
Description Simon Wilkinson 2001-04-02 12:42:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16_public-3.dcs.9 i686)

The pam_krb5 module doesn't initialise a number of variables which causes
it to segmentation fault if those variables are defined to a value other
than '0' by the compiler, or if krb5_init_context doesn't succeed.

In particular, config isn't initialised unless init_context() succeeds, so
can cause a seg fault when the DEBUG macro is run. In some portions of the
code 'ret' isn't initialised
either, so if it has a value other than 0, and init_context() succeeds
other problems
occur.

Reproducible: Always
Steps to Reproduce:
1. su to root
2. su to any other user.

Actual Results:  segmentation fault

Expected Results:  No segmentation fault

This occurs both with the pam_krb5 shipped with RedHat 6.2, and with the
latest one in Rawhide. I'm also using a later set of Kerberos libraries
than 6.2 ships with, but
this error is due to faults in the code.
Comment 1 Simon Wilkinson 2001-04-02 12:48:08 EDT
I neglected to add that I've got a patch for this, which I'm currently testing.
Comment 2 Simon Wilkinson 2001-04-02 13:00:02 EDT
Created attachment 14445 [details]
Patch to fix this against 1.26
Comment 3 Nalin Dahyabhai 2001-04-05 16:10:06 EDT
These should already be fixed in 1.30, which was pushed out as a bug-fix (for 7,
where changes in 1.2.2 were breaking pam_krb5's creation of credential caches).
Please reopen this bug ID if you find that there are problems with this version.
Thanks!

Note You need to log in before you can comment on or make changes to this bug.