Bug 343671 - cscope file list parsing broken when file names contain whitespaces
Summary: cscope file list parsing broken when file names contain whitespaces
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cscope   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Neil Horman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-20 00:51 UTC by Ronald Wahl
Modified: 2008-03-14 13:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 13:26:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ronald Wahl 2007-10-20 00:51:58 UTC
Description of problem:

Cscope is able to read a list of filenames from a file and index them
(cscope.files respective -i switch). If the file names contain spaces they need
to be quoted with double quotes. Sometimes this algorithm chokes and cscope
complains about non existing files with strange names. I guess some files get
not indexed in this case.

It seems that cscope 15.6 contains some fixes - according to the Changelog. So
probably cscope should be updated to the latest upstream version.

Version-Release number of selected component (if applicable):
cscope-15.5-15.4.fc7

How reproducible:
Here on my very large file list always but I cannot provide a simple case now as
for small test cases it seems to work.

Comment 1 Neil Horman 2008-03-14 13:07:00 UTC
I'll update this in rawhide, since I've been meaning to do it, and you can use
that package on F-7 directly, but F-7 itself is a little long in the tooth for
complete package revisions.  I should warn you though, Cscope is an old program,
and was never really intended to handle files with spaces in the names.  This
may never be something that works 100%

Comment 2 Neil Horman 2008-03-14 13:26:11 UTC
updated in rawhide,   Thanks!


Note You need to log in before you can comment on or make changes to this bug.