Bug 343771 - Unable to run Terminal due to missing exo library
Unable to run Terminal due to missing exo library
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
All Linux
high Severity high
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-20 08:27 EDT by Marcin Zajaczkowski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-20 17:38:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcin Zajaczkowski 2007-10-20 08:27:38 EDT
Description of problem:
Installation of Terminal (used by xfce4-panel) doesn't cause to install exo
library. As a result without manual installation of exo package Terminal doesn't
work at all.

Version-Release number of selected component (if applicable):
Terminal-0.2.6-3.fc7

How reproducible:
I did it once (but probably happens every time)

Steps to Reproduce:
1. Uninstall the whole xfce from a system
2. Install the whole xfce (at least Terminal with it's dependencies) using yum.
3. Try to run Terminal
  
Actual results:
Terminal: error while loading shared libraries: libexo-0.3.so.0: cannot open
shared object file: No such file or directory

Expected results:
Opened Terminal's window.

Additional info:
Almost fresh instalation without updates. yum-3.2.0-1.fc7
Comment 1 Marcin Zajaczkowski 2007-10-20 08:36:00 EDT
Hmm, as I see it's not a problem only with Terminal.

[szpak@szpak ~]$ rpm -e --test exo
error: Failed dependencies:
        libexo-0.3.so.0 is needed by (installed) Terminal-0.2.6-3.fc7.i386
        libexo-0.3.so.0 is needed by (installed) Thunar-0.8.0-1.fc7.i386
        libexo-0.3.so.0 is needed by (installed) xfdesktop-4.4.1-1.fc7.i386
        libexo-0.3.so.0 is needed by (installed)
xfce4-places-plugin-0.9.992-1.fc7.i386
        libexo-hal-0.3.so.0 is needed by (installed) Thunar-0.8.0-1.fc7.i386

exo was omitted for other packages too. I remember that I read long time ago
something about a problem with yum in f7. Can it be a reason?
Comment 2 Kevin Fenzi 2007-10-20 12:52:37 EDT
I don't see how you could have install Terminal with yum and not had it install
exo. Do you have any record of that yum transaction? Or can duplicate it? 

% rpm -q Terminal

Terminal-0.2.6-3.fc7

% rpm -q Terminal --requires | grep exo
libexo-0.3.so.0

% yum resolvedep 'libexo-0.3.so.0'
0:exo-0.3.2-2.fc7.i386

I played around with an f7 system here and couldn't duplicate. 
Can you do so there? Perferably with a yum -d6 output? 


Comment 3 Marcin Zajaczkowski 2007-10-20 17:38:29 EDT
I wasn't precise in my last message about installation method. I mentioned yum
(as an opposite to manual rpm -i ...), but in fact I called it from pirut. I
wasn't able to reproduce that with pure yum (dependencies were resolved
correctly). I played around with pirut and reproduced described issue.

1. Start pirut
2. Select a group "xfce" (with default components).
3. Click Apply.
4. Confirm package selection.
5. Click Cancel on additional dependencies.
6. Click Apply again from main window.
7. Confirm package selection.

Actual results:
Installation starts without question about additional dependencies. In fact they
are not installed at all.

Expected results:
pirut asks again about additional dependencies and when confirmed installs them
as well.

Affected version: pirut-1.3.7-1.fc7

pirut-1.3.9-1.fc7 seems to work fine. It's probably bug 242368 fixed in 1.3.8.
It was a fresh installed system with not updated packages.

So, it not related with Terminal. Sorry for a false suspicion.


*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.