Bug 3438 - cron mail sez' "cannot determine run level"
cron mail sez' "cannot determine run level"
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: crontabs (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-13 17:53 EDT by Jaroslaw Sosnicki
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 18:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 1999-06-13 17:53:31 EDT
I am getting this root email generated by cron with message
"Can not determine run level"
Comment 1 Jeff Johnson 1999-06-14 10:28:59 EDT
If typing "runlevel" gives the response "unknown", then check
/var/run/utmp* (which is where the current runlevel is stored. You'll
probably see a 0 length (or non-existent) file.

I've seen this behavior with initscripts-4.19 in Raw Hide. Reverting
to the 6.0 initscripts-4.16 fixed my prblem.
Comment 2 Bill Nottingham 1999-06-14 12:59:59 EDT
The initscripts-4.19 (and possibly 4.17, 4.18) problem is
fixed in initscripts-4.20; /var/run/utmp was getting removed
as soon as it was created (oops). Do you have a /var/run/utmp
or /var/run/utmpx?
Comment 3 Jaroslaw Sosnicki 1999-08-27 21:22:59 EDT
Yes I have /var/run/utmp. Since I reported this bug I have upgradet to
initscripts-4.32-2

Thanks for fixing it.

Note You need to log in before you can comment on or make changes to this bug.