Bug 344 - /usr/bin/passwd segfaults when using non-pwdb pam modules
/usr/bin/passwd segfaults when using non-pwdb pam modules
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pwdb (Show other bugs)
5.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-08 04:04 EST by Greg Retkowski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-10 18:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Retkowski 1998-12-08 04:04:15 EST
When using pam modules for naming services or authentication
databases not directly supported by pwdb (such as LDAP) the
passwd command will segfault. This is due to pwdb subverting
standard UNIX system calls that should be handled by the
Nameservice Switch (NSS) module (ie getpwuid, getpwnam).
Thus when a nameservice/pam module not known to pwdb is used
passwd.c (line 76) 'user' gets a null pointer and the
following strdup call causes a segmentation fault.
Comment 1 Cristian Gafton 1998-12-10 18:53:59 EST
pwdb needs a rewrite to be able to deal with that situation.

A future version of pwdb will use the nss modules for perorming the
user lookups. For now, using other modules is not supported. And for
things like ldap one will need a special passwd program anyway.

Note You need to log in before you can comment on or make changes to this bug.