Bug 344221 - grub boot mbr on sdb1 fails, no /root/dev again
grub boot mbr on sdb1 fails, no /root/dev again
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 01:55 EDT by Darwin H. Webb
Modified: 2008-08-06 16:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-06 16:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darwin H. Webb 2007-10-21 01:55:46 EDT
Description of problem:
Installed of rawhide-20071019-i686 on sdb
/boot1 /boot ext3 on sdb1
LVM on sdb2 (/root,/home/swap, emtryspace)

On bootup of system nothing would boot from grub.
root (hd1,0)
chainloader +1

root (hd1,1)
roonoverify (hd1,0)
chainloader +1

Checked /boot - looks good
checked /boot/grub - look good
checked /boot/grub/grub.conf - looks good.

Booted int sda1 grub, changed exiting titile lines
hd(o,0) to hd1,0)
changed root vg-lv name
system strated to boot and then it hung on the old
can't find /root/dev

I have booted other Linuxs and other system from the second hd.
I have installed other system from live cd's and only fedora keeps getting these
to bugs. Please make sure the final installed and boots from a separate hard
drive and that the /root/dev is fixed for good.



Version-Release number of selected component (if applicable):
rawhide-20071019-i686-live special 

How reproducible:
This has been going on since last year.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2007-10-22 16:21:35 EDT
Can you please provide exactly what you changed your grub config to be?
Comment 2 Darwin H. Webb 2007-10-30 14:33:31 EDT
The install created a boot and grub for the sdb1
But firstboot came up in grub sda1 and I tired many chainload formats to get to
the sdb1 grub but nothing worked.

So I edited an older grub line in sda1 as it bootted to use the new install kerenl
it was 
title
 root(hd1.0)
 kernel /vmlinuz-x.y.z.fc8 ro root=/dev/VG/LV 
 initrd /initrd-x.y.x.fc8.img

The first time I tied this I missing chaning the LV so it was not booint cand
hung. I saw what I did and corrected the LV name

That is when it started booting a normal but got the /rrot/dev/ not found

The only thing I can even guess at is that I unchecked the first drive from the
install and thus anaconda thinks it is using a one drive system and installs the
boot mbr on the sdb mbr rather than the first sector of the sdb1 but somehow
fails at booth. (Thats the only think I did on the installer other than click on
advanced boot option and indicate to put the boot sector on the fist sector of sdb1.

thanks,

Darwin

Comment 3 Darwin H. Webb 2007-10-30 18:43:11 EDT
OK, I installed the dvd F8 20071024 and got the same grub results.
I may not have ever installed a dvd on a second drive as that is usually the
release.

I used the fisrt part of anaaconda (remove all partitions, only sdb disk checked
for install, seleceted sdb disk to boot from.

Install ran fine and fisrtboot was into sda grub (no sign of sdb)
Tried all forms of chainloader + (no go)


edited a title in grub for sda to point to 
root (hd1,0)
edited the VG-LV to default of 00
edit version and initrd version to dvd kernel 31

The new install boot up perfect.

I look a /boot - ok
grub - ok

grub.conf  - NOT ok

the for boot is commited out
#/boot=dev/sdb

Below is the title showing 
root (hdo,o)  <<--- This is the problem, it should be root (hd1,0)

I never thoht of looking there before since it boots with the grub sda edit, but
then trying to figure out how it could boot at all without a boot sector lead me
there, because it can't.

So the root (hdn,0 must be changed to match the sdx (where x=n+1)

It would be good if it worked on install be at least the notes need to be changed.


The leaves only the /root/dev/ not found problem with the live install.
I will try that later and on use the same anaconda screens and see if it is
related to the root (hd0,0) problem.

Darwin
Comment 4 Darwin H. Webb 2007-10-30 20:46:12 EDT
OK, chainloader +1 just does NOT work even with the correct sdb grub.conf

I use
rootnoverify (hd1,0)
makeactive
chainloader +1

then press b

I get error 13 - non exicutable format.


There is simply NOT a boot sector on sdb1.

Darwin
Comment 5 Scott Stevens 2007-11-22 03:17:09 EST
I can confirm this. There is no boot sector being installed on (sdb1) when
directed to do so. It's being located on the MBR of sdb no matter what options
are selected. 
Comment 6 Bug Zapper 2008-04-04 10:13:56 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 7 Andy Lindeberg 2008-06-03 16:18:03 EDT
Have you encountered this problem in F9?

Note You need to log in before you can comment on or make changes to this bug.