Bug 344311 - mock broken during rebuild of package ktorrent
mock broken during rebuild of package ktorrent
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
http://linux.dell.com/files/fedora/Fi...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 07:25 EDT by Roland Wolters
Modified: 2013-01-09 20:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 12:57:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Part of the config log showing the qt-problem (2.50 KB, text/x-csrc)
2007-10-23 08:28 EDT, Roland Wolters
no flags Details

  None (edit)
Description Roland Wolters 2007-10-21 07:25:35 EDT
Description of problem:
Recently the mass package rebuild failed for my package "ktorrent" for the 
architecture x86 (and only for that one!).
The error is that Qt headers are not found:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/ktorrent-2.2.2-1.fc8.src.rpm/result/build.log

However, that should not have happened, the dependency on kdebase-devel should 
have worked as it did in the past and as they still does on the other 
architectures.

Since I have no idea what else could be broken I fill this bug report against 
mock.
Comment 1 Michael E Brown 2007-10-21 22:35:55 EDT
Not a bug in mock.

$ rpm -qp ktorrent-2.2.2-1.fc8.src.rpm --requires
kdelibs-devel  
gettext  
gmp-devel  
avahi-devel  
desktop-file-utils  
automake  
rpmlib(CompressedFileNames) <= 3.0.4-1

According to the root log, all of the 'requires' were installed:
http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-core/i386/ktorrent-2.2.2-1.fc8.src.rpm/result/root.log
--> search for 'yum --installroot'

As far as I can see, mock installed all of the deps that were specified and
their respective dep trees.
Comment 2 Roland Wolters 2007-10-22 05:40:09 EDT
But that doesn't explain why it works on x86_64.

And: kdebase-devel requires kdelibs-devel explicitely, and kdelibs-devel 
requires qt-devel:

http://cvs.fedoraproject.org/viewcvs/devel/kdebase/kdebase.spec?rev=1.272&view=markup
http://cvs.fedoraproject.org/viewcvs/devel/kdelibs3/kdelibs3.spec?rev=1.1&view=markup
Comment 3 Michael E Brown 2007-10-22 12:10:50 EDT
And if you look at the logs, they *are* being installed. qt-devel is installed
in the buildroot.
Comment 4 Roland Wolters 2007-10-23 08:28:54 EDT
Created attachment 235021 [details]
Part of the config log showing the qt-problem

This shows that the configuration checks for the wrong places. Is this a
problem with the config script, the environment variables or with the Qt
packages?

And why the hell does it work with x86_64? And why did it work with all the
other Fedora versions before?
Comment 5 Jesse Keating 2007-11-15 12:57:11 EST
I'm going to close this bug for now.  Please ensure (with scratch builds) that
ktorrent builds in koji.  If it fails again in the next mock rebuild test a new
bug will be opened.

Note You need to log in before you can comment on or make changes to this bug.