Bug 344341 - Hard to understand description in gnome-session-properties
Hard to understand description in gnome-session-properties
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 07:35 EDT by Bastien Nocera
Modified: 2008-09-09 18:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-09 18:42:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-10-21 07:35:51 EDT
pulseaudio-module-x11-0.9.7-0.16.svn20071017.fc8

1. Launch gnome-session-properties
2. In the Startup programs tab, "PulseAudio Session Management" has the comment
"Load module-x11-xsmp into PulseAudio". Why isn't this done in the esd startup
script instead?
Comment 1 Lennart Poettering 2007-10-22 10:36:29 EDT
Because of a deadlock between PA which is started as "esd", and gnome-session
which is starting it.

It's like this:

gnome-session acts as XSM session manager. When it starts up, it registers
itself as such, and then starts "esd" (which is just a wrapper script calling PA
with appropriate parameters), synchronously waiting for its full startup. Now,
if module-x11-xsmp is being loaded during PA's startup, we get a deadlock
because PA contacts the XSM session manager, which is gnome-session which is
however waiting for PA to startup and doesn't handle requests while doing that.
And we freeze at login.

To work around this PA starts up without XSMP support. And then, later, after
"esd"'s startup is complete and gnome-session handles XDG autostart we load XSM
support into the already running PA daemon.

I am not sure what you are requesting wit this bug report? A more elaborate
explanation in the XDG .desktop for for autostart? I'd say that would be too
elaborate for a .desktop file.

The whole problem will hopefully go away as soon as gnome-session and PA
integrate directly and more cleanly.

Are you OK if I close this bug as WONTFIX?
Comment 2 Matthias Clasen 2007-11-01 14:40:32 EDT
Closing this sounds fine to me. 
Comment 3 Bastien Nocera 2008-04-01 09:14:22 EDT
Reopening, as now it's gnome-settings-daemon that starts PA, and not
gnome-session, so the module could be loaded automatically on startup.

(FYI, the original bug report was about a better description for the .desktop file).
Comment 4 Bug Zapper 2008-05-13 23:41:39 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Lennart Poettering 2008-09-09 18:42:16 EDT
We now start PA from a normal XDG autostart desktop file. The xsmp specific desktop file is not longer used. This bug report hence no longer applies (all in rawhide).

Note You need to log in before you can comment on or make changes to this bug.