Bug 344511 - flegita cores when scanning muitple pages with ADF
flegita cores when scanning muitple pages with ADF
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomescan (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 11:39 EDT by Tim Taiwanese Liim
Modified: 2008-01-24 00:31 EST (History)
0 users

See Also:
Fixed In Version: Fedora8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 00:31:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace produced by bug-buddy. (13.45 KB, text/plain)
2007-10-21 11:39 EDT, Tim Taiwanese Liim
no flags Details

  None (edit)
Description Tim Taiwanese Liim 2007-10-21 11:39:50 EDT
Description of problem:
    flegita cores when scanning muitple pages with Automatic Document
    Feeder, using HP L7650 All-in-One connected via TCP, at
        gsb_convert_data_to_rgb () from /usr/lib/libgnomescan.so.0


Version-Release number of selected component (if applicable):
    gnomescan-0.4.0.2-1.fc7


How reproducible:
    always

Steps to Reproduce:
    1. run '/usr/bin/flegita' from command line, in KDE.
    2. connect to "HP Officejet Pro L7600" scanner.
    3. Source = Automatic Document Feeder (ADF)
       Fomat = US Letter
       File type = jpeg
    4. put in 3 pages (1-sided) in scanner ADF.
    5. in flegita, click 'Scan' button.
  
Actual results:
    flegita core dumps after
            Acquisition: 27333KB
    at
            #4  0x00e14bcc in memcpy () from /lib/libc.so.6
            #5  0x00116072 in gsb_convert_data_to_rgb () from
/usr/lib/libgnomescan.so.0
            #6  0x001174f3 in gsb_acquire_one () from /usr/lib/libgnomescan.so.0
            #7  0x00118480 in gnome_scan_backend_acquire () from
/usr/lib/libgnomescan.so.0
    See attached backtrace by bug-buddy.


Expected results:
    pages scanned and saved properly.

Additional info:
    Scanner is HP L7650 All-in-one network connected (not USB).
Comment 1 Tim Taiwanese Liim 2007-10-21 11:39:50 EDT
Created attachment 233631 [details]
backtrace produced by bug-buddy.
Comment 2 Deji Akingunola 2008-01-20 16:04:15 EST
I'm sorry for not attending to this bug for a long time. The upstream authors
have re-designed gnome-scan away from 0.4.0 series; the latest 0.5.3 version
however would not work in F-7 because it requires newer gtk2 lib than available
for F-7. Please upgrade to F-8 if you can, and try out the latest gnome-scan
package in the update-testing repo.
Comment 3 Tim Taiwanese Liim 2008-01-24 00:25:08 EST
Retested on FC8 on 1/23/08.  No more core dump seen.
Version used on 1/23/08:
    gnomescan-0.4.0.2-1.fc7
    kernel-2.6.23.9-85.fc8

Note that gnomescan was the same version (0.4.0.2-1.fc7) as the
one core dumped on 10/21/07, with F7.  Apparently some supporting
files changed in F8 and no more core dump.

Will close bug.

Note You need to log in before you can comment on or make changes to this bug.