Bug 344591 - java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Summary: java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
Status: CLOSED DUPLICATE of bug 301691
Alias: None
Product: Fedora
Classification: Fedora
Component: libxcb   
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-21 18:13 UTC by Need Real Name
Modified: 2007-12-18 23:25 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 15:18:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2007-10-21 18:13:20 UTC
$ ./java_program
java: xcb_xlib.c:50: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.

See http://en.opensuse.org/Xlib.lock

Comment 1 Need Real Name 2007-10-21 18:17:43 UTC
This hack works:
 cd /usr/java/jre1.6.0_01/lib/i386/xawt
 cp libmawt.so libmawt.so.bak
 sed -i ’s/XINERAMA/FAKEEXTN/g’ libmawt.so

Comment 2 Nitin Bansal 2007-10-22 08:27:01 UTC
NOTABUG afaik.

This seems to be a bug with java
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6532373

From Josh Triplett

The following workarounds address this problem:

For sun-java5-bin:
sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/lib/jvm/java-1.5.0-sun-1.5.0.11/jre/lib/i386/xawt/libmawt.so

For sun-java6-bin:
sed -i 's/XINERAMA/FAKEEXTN/g'
/usr/lib/jvm/java-6-sun-1.6.0.00/jre/lib/i386/xawt/libmawt.so

The same fix (applied to the appropriate file) might work for other
proprietary JDKs.



Comment 3 Adam Jackson 2007-10-22 15:18:35 UTC
It's a bug, but it's already fixed in icedtea.  We can't fix any other JDKs though.

*** This bug has been marked as a duplicate of 301691 ***

Comment 4 Craig Kelley 2007-12-18 23:25:05 UTC
Also see bug 301691


Note You need to log in before you can comment on or make changes to this bug.