Bug 344601 - ImportError: No module named parted
ImportError: No module named parted
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fwfstab (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Stewart Adam
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 14:15 EDT by Mace Moneta
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 0.02-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:04:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mace Moneta 2007-10-21 14:15:46 EDT
Description of problem:

Installed fwfstab-0.02-1.fc6.1 via yum.  Attempted to run it, received:

$ fwfstab
Traceback (most recent call last):
  File "/usr/share/fwfstab/fwfstab-runapp.py", line 23, in ?
    import callbacks
  File "/usr/share/fwfstab/callbacks.py", line 25, in ?
    import fwfstab, const
  File "/usr/lib/python2.4/site-packages/fwfstab/__init__.py", line 27, in ?
    import parted
ImportError: No module named parted


Version-Release number of selected component (if applicable):

fwfstab-0.02-1.fc6.1

How reproducible:

I repeated the installation on another system, same results.  It looks like 100%
reproducible.

Steps to Reproduce:
1.yum install fwfstab
2.fwfstab
3.Boom
  
Actual results:

Traceback (most recent call last):
  File "/usr/share/fwfstab/fwfstab-runapp.py", line 23, in ?
    import callbacks
  File "/usr/share/fwfstab/callbacks.py", line 25, in ?
    import fwfstab, const
  File "/usr/lib/python2.4/site-packages/fwfstab/__init__.py", line 27, in ?
    import parted
ImportError: No module named parted


Expected results:

A pretty fstab editor

Additional info: 

Is the package missing a requisite?  The parted package is installed:

$ rpm -qa | grep parted
gparted-0.3.3-3.fc6
parted-1.8.2-2.fc6
Comment 1 Stewart Adam 2007-10-21 14:48:12 EDT
If you install pyparted, does it solve this issue?
Comment 2 Mace Moneta 2007-10-21 14:57:00 EDT
Yes, installing pyparted resolves the problem.
Comment 3 Fedora Update System 2007-10-24 03:04:44 EDT
fwfstab-0.02-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Mace Moneta 2007-10-24 04:05:10 EDT
Apparently, it's also been pushed to FC6 extras, where this problem was
reported.  The problem is resolved.
Comment 5 Fedora Update System 2007-11-06 11:11:50 EST
fwfstab-0.02-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.