Bug 344611 - keyring continually prompts for key to unlock
keyring continually prompts for key to unlock
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 14:18 EDT by David Cantrell
Modified: 2008-03-24 08:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 13:15:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Cantrell 2007-10-21 14:18:15 EDT
The prompt to unlock the keyring keeps popping up over and over.  Annoying for
things like NetworkManager.
Comment 1 David Cantrell 2007-11-09 13:15:22 EST
Looks like I wasn't alone with this problem.  katzj told me my gnome-keyring
configuration files were wedged.  I ran this:

echo -n default > ~/.gnome2/keyrings/default

And it fixed up the problem.
Comment 2 d 2008-02-05 01:17:26 EST
Define "continually"...?

I was having it pop up precisely twice for me every time I rebooted my computer.
After attempting to use the method above to fix the problem, now is pops up even
more. I used to have just 2 files at ~/.gnome2/keyring/ and now I have three:

[root@localhost keyrings]# pwd; ls -ln
/home/[500]/.gnome2/keyrings
total 12
-rw-r--r-- 1 500 500    7 2008-02-04 21:22 default
-rw------- 1 500 500 1259 2008-01-22 20:51 default.keyring
-rw------- 1 500 500 1771 2008-01-30 00:42 login.keyring

Comment 3 ppaplaus 2008-03-07 18:20:40 EST
To unlock the keyring each user must have a password. A prompt for this password
will open when the user logs in. If the user enters the correct password, the
annoying prompt goes away. The 'bug' is caused by the original default keyring
password not being known by the user. 

The solution lies in the user knowing the keyring password for their user
account.  A simple solution is to delete the original keyring password and the
next session the user logs into, the user will be prompted to create a new one.

To do this: 
   Log in as the root (or individual user) and open a terminal
      "cd /home/[username]/.gnome2/keyrings" 
      *[username] is the account you wish to change
   List the contents of this directory ( 'ls' )
      -There should be two files: "default default.keyring"
   Delete the file "default.keyring"
      "rm -i default.keyring"
      (press y if you are deleting "default.keyring")
   List the contents of the directory again ( 'ls' )
      -There should only be one file: "default"
   Logout and login as that user and at the prompt, enter the new keyring
   password (to keep things simple, I recommend making it the same as your login
   password for that account)

To delete just one keyring, you can be the individual user deleting only their
keyring password. 

To delete multiple keyrings you will have to be the root user. 

To delete and change the keyring password  for the root account, the keyring
will found in "/root/.gnome2/keyrings"

NB: The ".gnome2" directory in all accounts is a hidden directory and cannot
navigated to with the file browser.
Comment 4 Jack 2008-03-24 08:21:33 EDT
A better solution would be to allow a system administrator to remove
gnome-keyring  functionality altogether.  Aside from being extremely annoying,
the keyring is just another subsystem that can break in ways which are
catastrophic for end-users. As a result this piece of dreck simply adds to a
sysadmins headache. Where are the instructions on how to remove/disable it ? 
What *%@# decided to enable keyring by default anyway ?!?!

Note You need to log in before you can comment on or make changes to this bug.