Bug 344671 - multilib conflict: man1/grmic.1.gz libgcj-4.1.2-32
multilib conflict: man1/grmic.1.gz libgcj-4.1.2-32
Status: CLOSED DUPLICATE of bug 341221
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 14:45 EDT by John Reiser
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 17:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Reiser 2007-10-21 14:45:06 EDT
Description of problem: Default install [base + Office Productivity] aborts
"Error running transaction; There was an error running your transaction, for the
following reason(s): file conflicts [Reboot]".  This was a DVD for x86_64
created by pungi using rawhide of Sat.Oct.20.  The detailed messages on vtty3:
"file conflicts: file /usr/share/man/man1/grmic.1.gz from install of
libgcj-4.1.2-32 conflicts with file from package libgcj-4.1.2-32" and the same
with jv-convert.1.gz.

This conflict was with all-default choices, so why wasn't it discovered by pungi
during the creation of the install DVD .iso?  Also, the message should be
improved to list the $ARCH in the name of the package.  The two package names in
each actual message are identical, so on the surface the complaint is nonsense.


Version-Release number of selected component (if applicable):
pungi-1.1.6-1.fc8


How reproducible: always using the created media; but re-creating the media by
re-running pungi encounters "phase of rawhide" non-reproducibility.

Steps to Reproduce:
1. edit usr/share/pungi/f8-fedora.ks to have "part iso --size=667" to fit onto
CD-RW of 700,000,000 bytes.
2. pungi -c /usr/share/pungi/f8-fedora.ks --destdir=/data/Fedora8 --name Fedora
--ver 8 --discs=4
3. install either the CDs or the DVD.  Error happens at the beginning of disc 3.
  
Actual results:
file conflicts: file /usr/share/man/man1/grmic.1.gz from install of
libgcj-4.1.2-32 conflicts with file from package libgcj-4.1.2-32

Expected results:
no conflicts

Additional info: Attempt to re-create on Sun.Oct.21 with only 1 disc (no "part
iso" and no "--discs=4") produced a different error ("exec of anaconda failed:
No such file or directory") which will be bz'ed separately.
Comment 1 Jesse Keating 2007-10-21 16:49:33 EDT
Pungi doesn't install the packages to create the isos.  It just puts the rpms in
a directory.  This is a bug in the libgcj package itself, not pungi.
Comment 2 Jakub Jelinek 2007-10-21 17:45:43 EDT

*** This bug has been marked as a duplicate of 341221 ***

Note You need to log in before you can comment on or make changes to this bug.