Bug 344691 - kernel-2.6.23.1-23.fc8 fails to resume
kernel-2.6.23.1-23.fc8 fails to resume
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 14:55 EDT by Osma Ahvenlampi
Modified: 2007-12-04 12:36 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.8-63.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-04 12:36:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -v -nn output (8.65 KB, text/plain)
2007-10-21 14:55 EDT, Osma Ahvenlampi
no flags Details

  None (edit)
Description Osma Ahvenlampi 2007-10-21 14:55:56 EDT
Description of problem:

laptop hard disk inaccessible after a suspend-to-ram-resume cycle. kernel prints
"journal commit I/O error" and "sd 0:0:0:0: [sda] Result:
hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK,SUGGEST_OK" (or something to that
effect, I had to write it down).

Version-Release number of selected component (if applicable):

kernel-2.6.23.1-23.fc8 known-bad, kernel-2.6.22.4-65.fc7 known-good. Sorry,
that's a wide window, I know.

How reproducible:

Every time.

Steps to Reproduce:
1. pm-suspend (or trigger the same by gnome-power-manager)
2. Resume
3. try to write to disk (or read outside of cache, I think)
Comment 1 Osma Ahvenlampi 2007-10-21 14:55:56 EDT
Created attachment 233651 [details]
lspci -v -nn output
Comment 2 Will Woods 2007-10-21 17:58:27 EDT
What kind of laptop? 
Comment 3 Osma Ahvenlampi 2007-10-22 02:50:02 EDT
Acer TravelMate 6292, Core 2 Duo, Santa Rosa chipset. The attachment has the
hardware details. I've been suspending and resuming this quite (but not 100%)
reliably through gnome-power-manager and hal since I got it this summer under
the F7 kernels. What instability I've had with it has been related to X and the
Intel driver, but these days that's quite good as well. I believe this is the
first kernel-related issue I've seen with the machine.
Comment 4 Osma Ahvenlampi 2007-10-23 15:40:12 EDT
Tighter window -- the last F7 update kernel kernel-2.6.22.9-91.fc7 works, and
the  first F8 test kernel kernel-2.6.23-0.164.rc5.fc8 does not.
Comment 5 Osma Ahvenlampi 2007-10-25 08:55:25 EDT
I found kernel-2.6.23.1-10.fc7 from koji. This kernel works. 
On the other hand, kernel-2.6.23.1-30.fc8 does not. I hope these are close
enough to each other to see the difference...
Comment 6 Osma Ahvenlampi 2007-11-04 11:47:35 EST
Still continue to have the problem with kernel-2.6.23.1-42.fc8. Certainly seems
to be some systematic difference between F7 and F8 kernel profiles.
Comment 7 Chuck Ebbert 2007-11-05 15:49:33 EST
Which kernel: i686 or x86_64?
Comment 8 Osma Ahvenlampi 2007-11-06 02:04:04 EST
Oh, sorry, neglected to mention that. i686.
Comment 9 Osma Ahvenlampi 2007-12-02 10:20:28 EST
kernel-2.6.23.8-63.fc8.i686 from updates-testing works

Note You need to log in before you can comment on or make changes to this bug.