Bug 344711 - kde-settings: Use fedora-bookmarks in konqueror
Summary: kde-settings: Use fedora-bookmarks in konqueror
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: KDE4Live
TreeView+ depends on / blocked
 
Reported: 2007-10-21 20:23 UTC by Sebastian Vahl
Modified: 2008-02-15 12:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 12:47:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Suse startscript which copies bookmarks.xml to the users homedir (8.32 KB, application/x-text)
2007-10-23 22:35 UTC, Sebastian Vahl
no flags Details
patch against startkde (772 bytes, patch)
2007-10-26 22:06 UTC, Sebastian Vahl
no flags Details | Diff
converted bookmarks.xml for usage in konqueror (50.61 KB, text/xml)
2007-10-26 22:07 UTC, Sebastian Vahl
no flags Details
/etc/kde/env/fedora-bookmarks.sh (407 bytes, application/x-shellscript)
2007-12-18 20:43 UTC, Sebastian Vahl
no flags Details
Patch against kde-settings.spec to inlcude bookmarks (1.58 KB, patch)
2007-12-18 20:45 UTC, Sebastian Vahl
no flags Details | Diff
converted bookmarks.xml for usage in konqueror (favicons updated) (51.58 KB, text/xml)
2008-02-14 19:16 UTC, Sebastian Vahl
no flags Details

Description Sebastian Vahl 2007-10-21 20:23:38 UTC
Description of problem:
I think we should use the bookmarks from fedora-bookmarks also in konqueror's 
web-browsing-mode. For this the bookmarks toolbar should be used in standard 
view of the web-browsing mode.

I don't know what would be the best steps to do this:
- create a dependency from kdebase to fedora-bookmarks and 
include /usr/share/bookmarks/default-bookmarks.html as a folder (if possible)
- import a snapshot from fedora-bookmarks before the new release of fedora.

Comment 1 Rex Dieter 2007-10-21 20:30:04 UTC
Definitely doable, but better placed in kde-settings somewhere... reassigning.

Comment 2 Sebastian Vahl 2007-10-23 22:35:08 UTC
Created attachment 235661 [details]
Suse startscript which copies bookmarks.xml to the users homedir

I tried to figure out how to integrate this and so looked into other
distributions: Suse has a folder in the bookmarks toolbar. 
It seems that they copy the bookmarks.xml (if it don't exist yet) from
/opt/kde3/share/config/SuSE/default/bookmark.xml (which seems to be the same as
our kde-settings) to the users ~/.kde/share/apps/konqueror/toolbar

I've attached their script so that you could have a look into it.

Comment 3 Sebastian Vahl 2007-10-26 22:06:26 UTC
I think coping the bookmarks.xml in /usr/bin/startkde if it is not existing in 
the users homedir would be the best. I've attached a patch for startkde with a 
short section of doing so. (I'm not sure where is the best place in startkde, 
I've picked on in the middle).

The second attachment is an imported bookmarks.xml from fedora-bookmarks-8-1. 
I've imported the bookmarks by hand and used "show folder in toolbar" to 
display them in konqueror's bookmarks toolbar.
The bookmarks.xml should be placed 
in /usr/share/kde-settings/kde-profile/default/share/apps/konqueror/bookmarks.xml 
(and also included there in kde-settings' tarball).

Comment 4 Sebastian Vahl 2007-10-26 22:06:59 UTC
Created attachment 239661 [details]
patch against startkde

Comment 5 Sebastian Vahl 2007-10-26 22:07:30 UTC
Created attachment 239671 [details]
converted bookmarks.xml for usage in konqueror

Comment 6 Rex Dieter 2007-10-26 22:57:35 UTC
If we want to implement this at session start, dropping a script into
/etc/kde/env makes more sense than patching startkde, imo.

Comment 7 Sebastian Vahl 2007-10-26 23:01:21 UTC
Ok. That would also be an option.

Comment 8 Sebastian Vahl 2007-12-18 20:43:30 UTC
Created attachment 289937 [details]
/etc/kde/env/fedora-bookmarks.sh

(In reply to comment #6)
> If we want to implement this at session start, dropping a script into
> /etc/kde/env makes more sense than patching startkde, imo.

ok. here it is.

Comment 9 Sebastian Vahl 2007-12-18 20:45:55 UTC
Created attachment 289938 [details]
Patch against kde-settings.spec to inlcude bookmarks

Additional sources are bookmarks.xml from comment #5 and fedora-bookmarks.sh
from comment #8.

Seems to work in kde4's konqueror. Only some (fav)icons are missing.

Comment 10 Sebastian Vahl 2008-02-14 19:16:04 UTC
Created attachment 294932 [details]
converted bookmarks.xml for usage in konqueror (favicons updated)

I really like to get this in KDE for F9. Any chance for that? Or any comments
on the given solution or a better one?

Comment 11 Ngo Than 2008-02-15 12:47:14 UTC
Sebastian, it looks sane to me. I will commit it into CVS and build it.

Thanks


Note You need to log in before you can comment on or make changes to this bug.