Bug 34473 - sa1 in adm crontab cannot write to /var/log/sa root
Summary: sa1 in adm crontab cannot write to /var/log/sa root
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sysstat (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-03 11:49 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 11:49:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-04-03 11:49:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT; Computer 
Associates International v1.16; Computer Associates International v1.52)


adm crontab contains /usr/lib/sa/sa1 and /usr/lib/sa/sa2
/var/log/sa owned by root, the adm user cannot write its crontab 
information to /var/log/sa

Reproducible: Always
Steps to Reproduce:
1.add sa1 and sa2 to 'adm' crontab
2.schedule sa1 to run every 5 minutes
3.check /var/log/sa, not files created

	

Actual Results:  no file created by sa1
mail output Cannot open /var/log/sa/sa07: Permission denied

Expected Results:  /var/log/sa/sa07 or the current date should exist
but it cannot because by default, /var/log/sa is owned by root

Comment 1 Preston Brown 2001-04-03 16:09:06 UTC
sa1 and sa2 are already run in /etc/cron.hourly/sysstat and
/etc/cron.daily/sysstat respectively.  They are run as root, not adm, so there
is no problem.

Comment 2 Need Real Name 2001-04-03 16:17:05 UTC
So I should not schedule sa1 or sa2 in adm's crontab.
Is this how Red Hat intends for sar to be run, only by root?

Comment 3 Need Real Name 2001-04-03 16:49:13 UTC
I will look at sysstat-3.2.4 to see if this changed.
I was unable to get sa03 or sa02 file for today or yesterday with sysstat-3.2.4.
I also have not discovered all the proper uses for this revision.
This has drastically different than the way I have used sar on any platform.

Now I don't have to deal with crontab anymore.
Sar just works.

Thanks for the comments.


Note You need to log in before you can comment on or make changes to this bug.