This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 344731 - Rsync "hosts allow" option works with IPv6 address but not with IPv4
Rsync "hosts allow" option works with IPv6 address but not with IPv4
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rsync (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Zeleny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-21 17:51 EDT by David Tonhofer
Modified: 2010-03-12 03:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-12 03:34:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2007-10-21 17:51:50 EDT
Description of problem:
-----------------------

The rsync program allows to restrict the origin of connections to an rsync
server instance by using the "hosts allow" directive in the rsyncd.conf
configuration file (or an other configuration file, as the case may be). See
rsyncd.conf(5).

The man page indicates that IPv4 or IPv6 addresses can be used as values to
"hosts allow".

However, if one uses an IPv4 address A.B.C.D as value (on a system where IPv6 is
enabled but not actively used) then the address of the connecting client is not
recognized. For example:

In case of "hosts allow = 88.207.188.205" the logfile say:

----------
forward name lookup for ip-88-207-188-205.dyn.luxdsl.pt.lu failed: Name or
service not known
rsync denied on module mayas-twiki-snapshot from unknown (::ffff:88.207.188.205)
----------

However,

In case of "hosts allow = ::ffff:88.207.188.205" the logfile say:

----------
forward name lookup for ip-88-207-188-205.dyn.luxdsl.pt.lu failed: Name or
service not known
rsync allowed access on module mayas-twiki-snapshot from unknown
(::ffff:88.207.188.205)
----------

...which is nice. So the workaround is straightforward. 

Note: I did not find an rsync bugzilla entry concerning this problem.

Version-Release number of selected component (if applicable):

rsync-2.6.3-1

How reproducible:

Always
Comment 1 David Tonhofer 2008-07-28 15:18:56 EDT
Just moved this to RHL5. 

hosts allow = ::ffff:88.207.188.205 will now fail

but 

hosts allow = 88.207.188.205 will succeed
Comment 2 Jan Zeleny 2010-03-05 05:16:17 EST
Could you please provide reference to RHEL5 bug if one exists? Since there is only one more release of RHEL4 planned and it will be focused on performance and security, this bug most likely won't be fixed in RHEL4.
Comment 3 David Tonhofer 2010-03-11 13:46:33 EST
Hi

There doesn't seem to be any (as it actually works in RHEL5). Well, this bug can probably be disregarded as there are no "Me Too"s to it, right? Also, it's old.
Comment 4 Jan Zeleny 2010-03-12 03:34:39 EST
Yes, that's my opinion as well. Thanks for cooperation, I'm closing this bug as WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.