Bug 344911 - volume keys change microphone's volume and not master volume. Thinkpad X61
volume keys change microphone's volume and not master volume. Thinkpad X61
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gstreamer (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 02:25 EDT by petrosyan
Modified: 2013-01-09 23:28 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.10.15-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 23:52:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sound Preferences Screenshot (56.00 KB, image/png)
2007-11-14 22:36 EST, petrosyan
no flags Details

  None (edit)
Description petrosyan 2007-10-22 02:25:08 EDT
Description of problem:
On a Thinkpad X61 machine "volume up/down" keys change microphone's volume
instead of changing master volume. "mute" key does not work at all.

Version-Release number of selected component (if applicable):
rawhide-20071019-x86_64 LiveCD session

How reproducible:
Always

Steps to Reproduce:
1. boot from rawhide-20071019-x86_64 live CD on a ThinkPad X61 machine.
2. press volume up/down keys.
3. realize that it is changing microphone's volume and not master volume
4. press mute button and nothing happens.

Additional info:
Hardware profile:
http://smolt.fedoraproject.org/show?UUID=dc726b49-3e2d-42ef-b633-253a5b6e0728
Comment 1 Jeremy Katz 2007-10-22 10:12:22 EDT
If you go into System->Preferences->Hardware->Sound what is selected for default
mixer tracks at the bottom of the capplet?
Comment 2 petrosyan 2007-10-22 11:12:02 EDT
Device: HDA Intel (Alsa mixer)
PCM
Micrphone
Mic Boost
Capture
Capture 1
Beep
Docking Mic
Docking Mic Boost
Internal Mic
Internal Mic Boost
Comment 3 petrosyan 2007-10-22 22:22:15 EDT
I have realized that the same bug exists in Ubuntu 7.10
https://bugs.launchpad.net/ubuntu/+bug/136287

The problem is that if you go into System->Preferences->Hardware->Sound nothing
is selected for the default mixer track and somehow the multimedia keys get
bound to microphone level by default. Choosing "PCM" track from the list fixes
the bug. However it should work by default as expected. So I am leaving this bug
open and hope it gets fixed before Fedora 8 release.
Comment 4 petrosyan 2007-11-14 22:36:31 EST
Created attachment 259341 [details]
Sound Preferences Screenshot

This problem is still present in Fedora 8. This is how "Sound Preferences"
window looks like right after install. As you can see none of the channels are
selected. By default the volume keys for some reason change microphone's
volume.
Comment 5 Bastien Nocera 2007-11-15 05:58:20 EST
I guess it means this doesn't work as it should on your system:
		/* If no track stored in GConf is avaiable try to use master track */
		if (self->_priv->mixer_tracks == NULL)
		{
			for (m = gst_mixer_list_tracks (self->_priv->mixer); m != NULL; m = m->next)
			{
				GstMixerTrack *track = GST_MIXER_TRACK (m->data);

				if (GST_MIXER_TRACK_HAS_FLAG (track, GST_MIXER_TRACK_MASTER)) {
					self->_priv->mixer_tracks = g_list_append (self->_priv->mixer_tracks,
g_object_ref (track));
					break;
				}
			}
		}
Comment 6 Jerone Young 2007-12-26 17:31:30 EST
The problem is NOT with control-center but with gstreamer. I have a fix on the
Ubuntu bugzilla.

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/174292
Comment 7 Ray Strode [halfline] 2008-01-02 10:35:15 EST
Thanks for the insight.
Comment 8 Jerone Young 2008-01-05 18:29:38 EST
I have placed a bugzilla in the gstreamer bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=506928
Comment 9 Bastien Nocera 2008-01-07 05:22:44 EST
I'll wait on feedback from upstream for that one. The patch seems to be more
intrusive than it needs to be, or a work-around.
Comment 10 Bastien Nocera 2008-01-07 10:07:39 EST
Test packages and feedback at:
https://admin.fedoraproject.org/updates/F8/pending/gstreamer-plugins-base-0.10.15-2.fc8
Comment 11 petrosyan 2008-01-07 11:47:52 EST
This bug is still present in gstreamer-plugins-base-0.10.15-2.fc8
Comment 12 Bastien Nocera 2008-01-07 12:26:05 EST
(In reply to comment #11)
> This bug is still present in gstreamer-plugins-base-0.10.15-2.fc8

Did you restart your session, or at least kill gnome-settings-daemon? The patch
added is the same reported as working by Jerone.
Comment 13 petrosyan 2008-01-07 12:30:50 EST
I upgraded to gstreamer-plugins-base-0.10.15-2.fc8 then rebooted the computer,
then created a new user. Logged in under the new user and volume keys were bound
to the microphone volume.
Comment 14 Bastien Nocera 2008-01-07 13:02:10 EST
I put the wrong patch in ;)
But I'm leaving it in as it fixes some issues with gnome-volume-control (and
it's my patch).
Comment 15 Bastien Nocera 2008-01-07 13:51:31 EST
Updated patches and errata at:
https://admin.fedoraproject.org/updates/F8/pending/gstreamer-plugins-base-0.10.15-3.fc8
Comment 16 petrosyan 2008-01-07 14:06:00 EST
gstreamer-plugins-base-0.10.15-3.fc8 is working as expected.
Comment 17 Fedora Update System 2008-01-11 17:10:19 EST
gstreamer-plugins-base-0.10.15-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gstreamer-plugins-base'
Comment 18 Fedora Update System 2008-02-12 23:52:52 EST
gstreamer-plugins-base-0.10.15-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.