Bug 345231 - nm-openvpn desktop file should have NoDisplay=true
Summary: nm-openvpn desktop file should have NoDisplay=true
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager-openvpn   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Tim Niemueller
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-10-22 14:15 UTC by Jeremy Katz
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-31 00:49:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2007-10-22 14:15:37 UTC
The desktop file included in the NetworkManager-openvpn package doesn't have
NoDisplay=True.  This means that we get a menu item under Internet for openvpn
network config which is a little ugly (you should get there from the NM vpn menu
item)

Given that we're including NetworkManager-openvpn in the desktop live images, we
should really get this fixed.

Comment 1 Tim Niemueller 2007-10-22 15:34:26 UTC
This has been fixed in the 0.6.x branch, but has not been merged into trunk.
Going to do this tonight when I'm back home.

Comment 2 Tim Niemueller 2007-10-29 00:04:57 UTC
This is just a ping that I'm working on it. The package needs to be updated (and
the upstream version to be increased) for NM 0.7. I'm currently working on this.
Will get this done hopefully today (Monday here).

Comment 3 Dan Williams 2007-10-29 01:41:42 UTC
Awesome; can you also test out the new openvpn plugin bits and see if they work?
 Tambet updated them but couldn't test them very well at all.  Thanks!

Comment 4 Tim Niemueller 2007-10-29 23:42:49 UTC
Still working on it. Getting closer though...

Comment 5 Tim Niemueller 2007-10-30 20:47:40 UTC
*darn* since I do not have a real virtual machine currently available and not
the time to set one up I'm installing in KVM now. Hope to make it before
Jeremy's deadline. Days are too short :-/

Comment 6 Tim Niemueller 2007-10-30 23:47:11 UTC
Ok, I did it, I packaged the new versions, but I could only do rudimentary
tests. Dan, the old version wouldn't work at all, would it? If so we are better
off using the current version anyway. See the koji build at
http://koji.fedoraproject.org/koji/taskinfo?taskID=221386

I couldn't build for the devel branch, as it couldn't find NetworkManager-devel
there for some reason. But that doesn't matter for now I guess since it is
already F9.

Jeremy, do I have to push an update for this or is it automatically included for
F-8 now?

Comment 7 Jeremy Katz 2007-10-31 00:49:13 UTC
Took care of it


Note You need to log in before you can comment on or make changes to this bug.