Bug 345351 - Opps, sealert hit an error!
Opps, sealert hit an error!
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: John Dennis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 11:15 EDT by Rex Basham
Modified: 2008-01-09 15:17 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 15:17:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Basham 2007-10-22 11:15:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070926 Fedora/2.0.0.6-11.fc8 Firefox/2.0.0.6

Description of problem:
Opps, sealert hit an error!

Traceback (most recent call last):
  File "/usr/bin/sealert", line 909, in <module>
    run_as_dbus_service(username)
  File "/usr/bin/sealert", line 159, in run_as_dbus_service
    app = SEAlert(username, dbus_service.presentation_manager, watch_setroubleshootd=True)
  File "/usr/bin/sealert", line 613, in __init__
    self.browser = BrowserApplet(self.username, self.alert_client)
  File "/usr/lib/python2.5/site-packages/setroubleshoot/browser.py", line 887, in __init__
    self.init_widgets()
  File "/usr/lib/python2.5/site-packages/setroubleshoot/browser.py", line 1142, in init_widgets
    self.browser_win.set_icon_from_file(logo_file)
TypeError: GtkWindow.set_icon_from_file() argument 1 must be string, not None


Version-Release number of selected component (if applicable):
setroubleshoot-server-1.9.4-2.fc7
setroubleshoot-server-1.10.7-1.fc8

How reproducible:
Always


Steps to Reproduce:
1. run level 3, login
2. manually enter startx
3. error box pops up in middle of the x session window

Actual Results:
?

Expected Results:
I assume someone left out a needed parm from the error text:
TypeError: GtkWindow.set_icon_from_file() argument 1 must be string, not None


Additional info:
setroubleshoot-server-1.9.4-2.fc7
setroubleshoot-server-1.10.7-1.fc8

not sure which one it is using when the error hits both are installed.  I have the debugging enabled to chase another problem.
Comment 1 John Dennis 2008-01-09 15:17:35 EST
Thank you for reporting this. In all honesty I'm not sure what to do with it.
The code which generated the traceback does not exist anymore because it was
rewritten. Plus you can't install two simultaneous versions, that's just a
recipe for problems (and I think it was the root cause because the config file
didn't match the version). So I think I'm just going to close this, I don't
think it's worth trying to track down at this point but I very much appreciate
your time and effort in reporting it nonetheless.

Note You need to log in before you can comment on or make changes to this bug.