Bug 34536 - Installer can't read installed RPM database on upgrade
Installer can't read installed RPM database on upgrade
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 15:29 EDT by kevin_myer
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-10 18:10:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kevin_myer 2001-04-03 15:29:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.28enterprise i686)


I have one Red Hat 5.2 server that I want to upgrade to 6.2 to bring it in
line with all of our other servers.  I tried both the original bootnet.img
and the bootnet-20000407.img and both give me the same error.  I boot the
machine from floppy, make some choices and select "Upgrade existing
installation".  The installer attempts to determine what RPMs are installed
and this causes a crash, the last line being:

line 730, in upgradeFindPackages packages =rpm.findUpgradeSet
	(self.hdList.hdlist, self.initPath) rpm.error: error during upgrade check)

The 5.2 machine has all the latest upgrades installed and I suspect that
this problem comes from the 4.0.2 rpm upgrade and subsequent RPM database
rebuild (in otherwords, I doubt the 6.X installer knows about the new
database format).

This is problematic because that means that any 5.2, 6.0, or 6.1 machine
can't be upgraded to 6.2 until the 6.2 installer can recognize db3
databases.  Taking the machine to 7.0 or 7.1, when its released, isn't an
option, since I normally don't upgrade until the X.2 releases.

Any suggestions (or have I misdiagnosed the problem?)

Thanks,

Kevin

Reproducible: Always
Steps to Reproduce:
1.Boot from bootnet.img floppy
2.Select Upgrade existing installation
3.
	

Actual Results:  Crash

Expected Results:  Installer should obtain list of installed RPMS and
continue
Comment 1 Michael Fulbright 2001-04-11 11:49:55 EDT
Matt is there a workaround for this problem?
Comment 2 Matt Wilson 2001-07-20 16:15:28 EDT
run rpm --rebuilddb on your system and try again.
Comment 3 kevin_myer 2001-07-30 14:00:23 EDT
How is rebuilding a RPM 4.X, db3 database going to help in installing a version
of RedHat that is based on RPM 3.X, db1?    You need to 1) update the Red Hat
6.X series of installers to be RPM 4.X aware or 2) provide a means to downgrade
RPM and db versions (from 4.X to 3.X and db3 to db1 respectively) so that that
the 6.X installers will work or 3) require all upgrades be to 7.1 (or maybe 7.0
if that supports RPM 4.X and db3).

I'm not sure what the solution is - so far it appears to be #3, based on the
_looooooong_ time its taken you to respond to this bug posting.  If this is a
planned and forced obselescence of the 5.X series, thats fine - just let it be
publicly known before you make changes that orphan a particular distro version
so we can plan our upgrade paths appropriately.
Comment 4 Matt Wilson 2001-08-06 15:23:17 EDT
the installer knows about all RPM database formats.  It just needs to be
consistent before the upgrade process begins.
Comment 5 Brent Fox 2001-08-10 18:10:06 EDT
The installer is compatible with previous versions of Red Hat Linux (back to
3.0.3, but not earlier than that).  Did you try msw's recommendations and did
you have any luck with them?
Comment 6 Brent Fox 2001-08-20 09:54:21 EDT
Closing due to inactivity. Please reopen if you have more information.
Comment 7 kevin_myer 2001-08-23 13:50:15 EDT
Sorry I didn't get back to you sooner on this; I was on vacation.  The system in
question did have the rpmdb rebuilt immediately after I upgraded to RPM 4.X
months ago.   As this machine was recently retired and as it was my only
remaining Red Hat 5.2 machine, I don't really have anything to test against and
am not interested enough to install 5.2 just to resolve this.  Thanks for the
suggestions and keep up the good work.

Note You need to log in before you can comment on or make changes to this bug.