This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 3454 - Certain programs crash Linux just starting
Certain programs crash Linux just starting
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-14 10:05 EDT by rri0189
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-12 13:22:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rri0189 1999-06-14 10:05:09 EDT
There is a library used in RH Linux 6.0 to produce fake-GUI
in text mode.  It is used by linuxconf sometimes (when not
in X or when not run by root), and by sndconfig always.  I
have no idea of what its name is, or what other programs may
use it, or whether it is from RH or someone else.  It's not
simply curses; I have curses programs that work fine.  It
works OK when X is not running (e.g., when booted
single-user), but when a program using this package
(whatever its name may be) runs on my system in a console
window (e.g., open a window, type "sndconfig" and hit
Return), its logical screen flashes into place in the window
for a fraction enough of a second (enough to read one or two
words and see that the program is starting) and then my
entire screen turns black and there is nothing for it but
the Reset button and fsck.

I cannot make any attempt to make practical use of a system
with such a bug lying in wait, and with no knowledge of what
other programs may trigger it.  RH Installation support says
it ain't their problem.  W95 tells me that my video board is
a "S3 ViRGE 325 PCI".
Comment 1 Jay Turner 1999-06-14 13:23:59 EDT
Could you send us some debugging output from one of these crashes?
Without that, I really cannot attempt to recreate your problem.
Comment 2 rri0189 1999-06-14 15:44:59 EDT
You'll have to tell me how to go about it.  All I'm seeing now is a
quick and total system crash, with no visible information.  Is there a
trace I can turn on with a reasonable hope of surviving fsck?

In the meantime, can you help me narrow down the problem so that I can
ask intelligent questions?  Do you know what the name of this fake-GUI
library used by linuxconf and sndconfig is?  Where it's from?  Where
else it's used?
Comment 3 Bill Nottingham 1999-06-14 17:34:59 EDT
It's called newt, and it shouldn't be doing anything silly, AFAIK.
Is gpm running on your system?

One thing that can help is if you can telnet into the machine after
the display locks... can you do this?

------- Additional Comments From   06/14/99 18:03 -------
gpm is installed.  I can't say offhand whether it's
"running".

I'm not on any sort of LAN -- this is my home
system -- so I can't literally telnet in.  I
suppose I can get a crossover cable and use a
dumb-terminal program on my laptop to get in
through a serial port, but it will take me a day or
two, if only to buy the cable.

For what it's worth, Ctrl-Alt-Del is dead, but I've
used Linux so little thus far that I don't even
know whether that's normal.

------- Additional Comments From   06/14/99 19:16 -------
In the meantime, here's one additional piece of information.  The
failure only occurs under gnome.  kde, anotherlevel and failsafe are
all OK.
Comment 4 Bill Nottingham 1999-06-15 17:57:59 EDT
That's really strange that it would crash in gnome and
not kde, etc.

One way to tell if gpm is running is to do
'ps aux | grep gpm' before you run
whatever - this will show something like:

root       528  0.0  0.4  1112  300 ttyS0    S    17:34   0:00 gpm -t
MouseMan

if it is...
Comment 5 rri0189 1999-07-01 10:39:59 EDT
Sorry about the delay, but my computer and I had a deadline to deal
with, and playing with Linux had to go on the back burner.

I, too, was puzzled by the discrepancy between environments, until it
occurred to me that one difference would be the font used for terminal
windows.  I changed fonts, and, hey presto! the problem vanished.
Fortunately/unfortunately, I also cannot reproduce the problem any
more.
Comment 6 Preston Brown 1999-07-12 13:22:59 EDT
problem seems to have corrected itself.

Note You need to log in before you can comment on or make changes to this bug.