Bug 345491 - deselect virtualization subset, kernel-xen still installs
deselect virtualization subset, kernel-xen still installs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Joel Andres Granados
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 12:32 EDT by Aron Griffis
Modified: 2008-07-31 04:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 04:45:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2007-10-22 12:32:01 EDT
Description of problem:
During installation, check "virtualization", go forward, go back, uncheck
"virtualization", go forward, complete installation, "virtualization" is installed.

Version-Release number of selected component (if applicable):
5.1rc2
anaconda-11.1.2.87-1
kernel-xen-2.6.18-53.el5xen

How reproducible:
every time

Steps to Reproduce:

1. Check [*] Virtualization when installing, then hit [OK]

    +----------------+ Package selection +-----------------+
    |                                                      |
    | The default installation of Red Hat Enterprise       |
    | Linux Server includes a set of software applicable   |
    | for general internet usage. What additional tasks    |
    | would you like your system to include support for?   |
    |                                                      |
    |               [ ] Software Development               |
    |               [*] Virtualization                     |
    |               [ ] Web server                         |
    |                                                      |
    |                                                      |
    |           [ ] Customize software selection           |
    |                                                      |
    |          +----+                   +------+           |
    |          | OK |                   | Back |           |
    |          +----+                   +------+           |
    |                                                      |
    |                                                      |
    +------------------------------------------------------+

2. Choose [Back] instead of continuing.

    +---------+ Installation to begin +----------+
    |                                            |
    | A complete log of your installation will   |
    | be in /root/install.log after rebooting    |
    | your system. You may want to keep this     |
    | file for later reference.                  |
    |                                            |
    |       +----+              +------+         |
    |       | OK |              | Back |         |
    |       +----+              +------+         |
    |                                            |
    |                                            |
    +--------------------------------------------+

3. Uncheck [ ] Virtualization this time, hit [OK]

    +----------------+ Package selection +-----------------+
    |                                                      |
    | The default installation of Red Hat Enterprise       |
    | Linux Server includes a set of software applicable   |
    | for general internet usage. What additional tasks    |
    | would you like your system to include support for?   |
    |                                                      |
    |               [ ] Software Development               |
    |               [ ] Virtualization                     |
    |               [ ] Web server                         |
    |                                                      |
    |                                                      |
    |           [ ] Customize software selection           |
    |                                                      |
    |          +----+                   +------+           |
    |          | OK |                   | Back |           |
    |          +----+                   +------+           |
    |                                                      |
    |                                                      |
    +------------------------------------------------------+

4. Finish the installation
  
Actual results:
kernel-xen is installed (and boots by default)

Expected results:
kernel-xen is not installed
Comment 1 Chris Lumens 2007-10-22 13:52:08 EDT
What does rpm -q --whatrequires kernel-xen show on the running system?
Comment 2 Aron Griffis 2007-10-22 14:56:43 EDT
# rpm -q --whatrequires kernel-xen
no package requires kernel-xen

Since reporting, I've tested on x86_64, happens there too; changing Hardware
from IA64 to All.
Comment 3 Aron Griffis 2007-10-22 15:04:11 EDT
Btw when following these steps, both kernel and kernel-xen are installed on the
system.  True on both ia64 and x86_64
Comment 5 Aron Griffis 2008-07-30 18:17:37 EDT
Problem seems to be resolved in RHEL5.2, suggest closing this bug

Note You need to log in before you can comment on or make changes to this bug.