Bug 34551 - Powering off USB printer results in useless system
Summary: Powering off USB printer results in useless system
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-03 20:58 UTC by ajs
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 01:47:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Best possible band-aid for the problem. (665 bytes, patch)
2001-04-08 04:10 UTC, Pete Zaitcev
no flags Details | Diff
More thoughrow fix by David-B (8.24 KB, patch)
2001-06-12 21:06 UTC, Pete Zaitcev
no flags Details | Diff

Description ajs 2001-04-03 20:58:28 UTC
If I power down my USB printer (HP 880C) while printing, then the USB
printer driver gets stuck in the function usblp_write in printer.c.  When
under X, all of the other USB devices seem to turn off (LEDs shut off) and
there is no response from anything.  When in a console, the error message

 printer.c: usblp0: error -110 writing to printer

endlessly streams across the screen and the system is useless (the LEDs of
other USB devices stay on though).  Turning the printer back on does not
seem to help, but I only waited a half a minute or so.

repeatability: always
kernel RPM: kernel-2.4.2-0.1.28

Tony

Comment 1 Pete Zaitcev 2001-04-08 04:10:42 UTC
Created attachment 14884 [details]
Best possible band-aid for the problem.

Comment 2 Pete Zaitcev 2001-04-08 04:14:25 UTC
Sleeping for 50 ticks is too little and will cause
a message flooding on unattended print servers.
Let's make it 1000 (10s).


Comment 3 ajs 2001-04-09 16:13:16 UTC
I will try this patch as soon as I can, but this is looking like a busy week.

One concern though:  When I power down the printer while running X, all of
my other USB devices shut off.  Is the 10s timeout going to mean that the other
devices are inoperable for 10s?

Tony


Comment 4 Pete Zaitcev 2001-04-10 01:47:44 UTC
If my analysis is correct, the recovery needs a small
fraction of a second for khubd to pick up and enable
ports. This is why I put only 0.5s into the schedule_timeout
at first. The printing application will be delayed
until a write awakens, for 10s.


Comment 5 Pete Zaitcev 2001-04-17 20:34:51 UTC
I had to put the fix off because we were in a freeze
for the 7.1 release. In CVS now, will come with errata.


Comment 6 Pete Zaitcev 2001-06-12 21:06:19 UTC
Created attachment 20902 [details]
More thoughrow fix by David-B


Note You need to log in before you can comment on or make changes to this bug.