Bug 345521 - NM doesn't auto connect
Summary: NM doesn't auto connect
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-22 16:44 UTC by Brian G. Anderson
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 03:12:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brian G. Anderson 2007-10-22 16:44:34 UTC
Description of problem:
Network manager refuses to connect automatically to wireless or wired network. 
I always have to manually select the connection I want.  It fails to
1) connect to a wired or wireless connection on resume
2) connect to wireless connect on login
3) connect to wireless connection on disconnect of wired connection
4) connect to wired connection after reconnecting.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.3.svn2983.fc8

How reproducible:
everytime


Steps to Reproduce:
1.
2.
3.
  
Actual results:
I must use the applet menu to select the connection

Expected results:
Automatic selection

Additional info:
Dell Lattitude D620 using the b43 wireless driver.

Comment 1 Dan Williams 2007-10-22 17:28:01 UTC
could you make sure the connections are marked autoconnect?  Up to and including
Test3, autoconnect was not set as default because the code wasn't there to let
NM choose the correct network.  So if you haven't cleared your GConf since
Test3, you'll probably have the 'autoconnect' option not set.

Run 'gconf-editor' and drill down to /system/networking/connections.  You'll see
a list of the connections.  Run through them and in the 'connection' folder of
each one you want to autoconnect, and check the 'autoconnect' option.

Comment 2 Brian G. Anderson 2007-10-22 17:52:12 UTC
Yup that was it.  I works fine now.  Sorry for the false alarm.

Comment 3 Dan Williams 2007-10-27 03:12:44 UTC
no problem, thanks for the report!


Note You need to log in before you can comment on or make changes to this bug.