Bug 3456 - Perceptive Solutions' third party SCSI drivers
Perceptive Solutions' third party SCSI drivers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
: 3457 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-14 12:03 EDT by psitech
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description psitech 1999-06-14 12:03:59 EDT
My name Oswaldo Rodriguez, I work for a company called
PSI (Perceptive Solutions, Inc.)  There are problems with
the installation of our third party SCSI drivers on your
Redhat 6.0 distribution diskette. Our drivers are in the
sources on the Redhat 6.0 distribution CD, but are not
included in the built kernel. While they should be included
as SCSI modules some of them were not marked as such in the
default kernel configuration.  Similar problems appear to
also affect other third party SCSI providers.

The script for driver selection lists only one of the three
drivers we furnished (and that are included in the
sources).
During Installation, messaging appears that indicates two
of
the three drivers (including the only one selectable during
installation) were not configured as modules. This prevents
generation of the target system.

Another problem is that any kernel built using the sources
supplied fails with a version mismatch during the "boot
loader installation" step. Manually running insmod reports
that loop.0 was built with version 2.2.5-14BOOT while the
generated kernel is reported as version 2.2.5-15.

This problem prevents the installation of the boot loader
in
an otherwise fully functional (although manually generated)
working system.

With these problems, there is NO practical mechanism for a
normal user to install our drivers using the Redhat 6.0.
While our drivers have no problems running in 6.0, getting
them installed with the scripts Redhat has generated is a
problem.

Correcting the configuration (M for module instead of NO)
should address one of the immediate problems problems with
the 6.0 as distributed.  The problem of upgrades (or field
addition of SCSI drivers) however, will remain until the
version mismatch problem is addressed.

We would like to work with Redhat to eliminate these
problems so the full value of 6.x can be accessible. Please
feel free to contact us for hardware or any other support
we
can offer. We hope that these problems can be addressed in
the near term.

On a separate matter, we would like to suggest that the
default for SCSI generic support (in the kernel) be set to
ON (currently it is off). This fairly small module provides
some powerful support. For us, it is a standard mechanism
for an application to obtain RAID status information and
manage hot swap and reconstruct. Currently it is necessary
to build the kernel in order to utilize this feature.

Thank you....


P.S.  Once we get this resolved we need to also be placed
on
your hardware compatabilty list.
Comment 1 Jeff Johnson 1999-06-14 12:17:59 EDT
Doug, can you answer this? Thanks ...
Comment 2 Jeff Johnson 1999-06-14 13:18:59 EDT
*** Bug 3457 has been marked as a duplicate of this bug. ***

My name Oswaldo Rodriguez, I work for a company called
PSI (Perceptive Solutions, Inc.)  There are problems with
the installation of our third party SCSI drivers on your
Redhat 6.0 distribution diskette. Our drivers are in the
sources on the Redhat 6.0 distribution CD, but are not
included in the built kernel. While they should be included
as SCSI modules some of them were not marked as such in the
default kernel configuration.  Similar problems appear to
also affect other third party SCSI providers.

The script for driver selection lists only one of the three
drivers we furnished (and that are included in the
sources).
During Installation, messaging appears that indicates two
of
the three drivers (including the only one selectable during
installation) were not configured as modules. This prevents
generation of the target system.

Another problem is that any kernel built using the sources
supplied fails with a version mismatch during the "boot
loader installation" step. Manually running insmod reports
that loop.0 was built with version 2.2.5-14BOOT while the
generated kernel is reported as version 2.2.5-15.

This problem prevents the installation of the boot loader
in
an otherwise fully functional (although manually generated)
working system.

With these problems, there is NO practical mechanism for a
normal user to install our drivers using the Redhat 6.0.
While our drivers have no problems running in 6.0, getting
them installed with the scripts Redhat has generated is a
problem.

Correcting the configuration (M for module instead of NO)
should address one of the immediate problems problems with
the 6.0 as distributed.  The problem of upgrades (or field
addition of SCSI drivers) however, will remain until the
version mismatch problem is addressed.

We would like to work with Redhat to eliminate these
problems so the full value of 6.x can be accessible. Please
feel free to contact us for hardware or any other support
we
can offer. We hope that these problems can be addressed in
the near term.

On a separate matter, we would like to suggest that the
default for SCSI generic support (in the kernel) be set to
ON (currently it is off). This fairly small module provides
some powerful support. For us, it is a standard mechanism
for an application to obtain RAID status information and
manage hot swap and reconstruct. Currently it is necessary
to build the kernel in order to utilize this feature.

Thank you....


P.S.  Once we get this resolved we need to also be placed
on
your hardware compatabilty list.
Comment 3 psitech 1999-06-28 12:54:59 EDT
Any progress on my bug report?
Comment 4 psitech 1999-07-13 17:33:59 EDT
Please let me know if you guys are working on this.  It is imperitive.

Note You need to log in before you can comment on or make changes to this bug.