Bug 345611 - spew when machine doesn't support acpi
spew when machine doesn't support acpi
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: acpid (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Zdenek Prikryl
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-22 13:22 EDT by Jeremy Katz
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 16:49:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2007-10-22 13:22:14 EDT
If running on a machine that doesn't support ACPI (such as qemu/kvm virtual
machines), the acpi initscript spews 
  /etc/init.d/acpid: need ACPI_PROC_EVENT support in kernel.  //zmena podle 260181
It should probably just silently not start if the /proc/acpi dir doesn't exist.

While cosmetic, this is highly visible with the Fedora 8 live images in
situations that are likely to be tried by reviewers, etc.
Comment 1 Zdenek Prikryl 2007-10-23 05:03:34 EDT
Hello,
I'm not sure, if it is good to do not print anything. Because if no message is
printed, then someone can assume that everything is fine. I think better
solution is print "Starting acpid daemon [failure]" and in /var/log/messages
have more info about a problem.

Zdenek
Comment 2 Jeremy Katz 2007-10-23 10:00:23 EDT
The normal behavior of many services is "hardware not present, initscript exits
early and silently".  

So basically very early in the initscript, just 
[ -d /proc/acpi ] || exit 0
Comment 4 Will Woods 2007-10-23 16:49:12 EDT
New build should show up in tomorrow's rawhide.

Note You need to log in before you can comment on or make changes to this bug.