This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 345621 - latest texinfo causes other builds to fail when looking for makeinfo
latest texinfo causes other builds to fail when looking for makeinfo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2007-10-22 13:30 EDT by Doug Chapman
Modified: 2007-12-21 08:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-21 08:17:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-10-22 13:30:10 EDT
Description of problem:
I do not claim to understand why but under F8T3 with texinfo-4.11-1.fc8
installed several other .src.rpm builds will fail because configure claims to
not be able to find makeinfo (even though it is there):

configure: WARNING:

*** Makeinfo is missing. Info documentation will not be built.


then later during the build:

WARNING: `makeinfo' is missing on your system.  You should only need it if

         you modified a `.texi' or `.texinfo' file, or any other file

         indirectly affecting the aspect of the manual.  The spurious

         call might also be the consequence of using a buggy `make' (AIX,

         DU, IRIX).  You might want to install the `Texinfo' package or

         the `GNU make' package.  Grab either from any GNU archive site.

make[3]: *** [standards.info] Error 1



The worst case of this is binutils fails to build.  I confirmed that if I go
back to texinfo-4.9-1.fc8 then the problem goes away.

I ran into this when trying to build binutils for ia64 however I have also
reproduced on x86_64.  It likely has not been reported because x86_64 binutils
has not changed and hence has not needed a rebuild

Version-Release number of selected component (if applicable):
texinfo-4.11-1.fc8

How reproducible:
100%

Steps to Reproduce:
1. Install F8T3
2. confirm you have texinfo-4.11-1.fc8
3. rpmbuild --rebuild -bb binutils-2.17.50.0.18-1.src.rpm
  
Actual results:
configure stage 

Expected results:


Additional info:
Comment 1 Jan Kratochvil 2007-10-29 10:20:05 EDT
This is a bug in binutils, not in texinfo.
Texinfo just increased its version number.
It should be fixed either with the next binutils snapshot-release or by
importing the following patch:
http://cvs.fedora.redhat.com/viewcvs/rpms/gdb/F-7/gdb-6.6-upstream.patch?r1=1.6&r2=1.7&sortby=date&makepatch=1&diff_format=h
Comment 2 Jeffrey Moyer 2007-11-02 12:46:31 EDT
*** Bug 323181 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Jelinek 2007-12-21 08:17:28 EST
Should be fixed in 2.18.50.0.3-1 in rawhide.

Note You need to log in before you can comment on or make changes to this bug.