Bug 345881 - GNOME Copy and Paste buffer is lost
GNOME Copy and Paste buffer is lost
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: control-center (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Control Center Maintainer
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 15:57 EDT by Andrew Case
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 06:43:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace -s512 -p 8758 (178.04 KB, text/plain)
2007-10-22 17:05 EDT, Andrew Case
no flags Details

  None (edit)
Description Andrew Case 2007-10-22 15:57:51 EDT
Description of problem:

When using GNOME 2.16 in RHEL5, if I highlight text in a using the mouse, then
paste using the middle button on my mouse into another application this works. 
If however I highlight text in an application, then close all instances of that
application, then paste using the middle mouse button into another application,
the buffer is empty and nothing is pasted.

This feature works fine in RHEL5's KDE.

This is can be extremely annoying.


Version-Release number of selected component (if applicable):

Here are all the gnome/gtk rpms installed, I'm not sure which package actually
handles the copy/paste mechanism.

gnome-user-docs-2.16.0-2.fc6
gnome-desktop-2.16.0-1.fc6
libgail-gnome-1.1.3-1.2.1
gnome-vfs2-smb-2.16.2-4.el5
gnome-terminal-2.16.0-3.el5
gnome-python2-extras-2.14.2-4.fc6
libgnomecups-0.2.2-8
gnome-python2-libegg-2.14.2-4.fc6
gnome-panel-devel-2.16.1-6.el5
gnome-spell-1.0.7-3.1
gnome-mag-0.13.1-1.fc6
gnome-vfs2-2.16.2-4.el5
libgnomeprint22-2.12.1-9.el5
gnome-python2-2.16.0-1.fc6
gnome-python2-gnomeprint-2.16.0-1.fc6
libgnome-devel-2.16.0-6.el5
gnome-desktop-devel-2.16.0-1.fc6
gnome-audio-2.0.0-3.1.1
libgnomeprintui22-2.12.1-6
gnome-netstatus-2.12.0-5.el5
gnome-utils-2.16.0-3.el5
gnome-mime-data-2.4.2-3.1
gnome-backgrounds-2.15.92-1.fc6
gnome-keyring-0.6.0-1.fc6
libgnomecanvas-devel-2.14.0-4.1
libgnomeui-2.16.0-5.el5
gnome-panel-2.16.1-6.el5
gnome-panel-2.16.1-6.el5
gnome-volume-manager-2.15.0-4.el5
gnome-panel-devel-2.16.1-6.el5
libgnome-devel-2.16.0-6.el5
bluez-gnome-0.5-5.fc6
gnome-keyring-0.6.0-1.fc6
gnome-menus-2.16.0-2.fc6
libgnome-2.16.0-6.el5
libgnomeprint22-2.12.1-9.el5
gnome-screensaver-2.16.1-5.el5
gnome-media-2.16.1-3.el5
gnome-python2-gtksourceview-2.16.0-1.fc6
gnome-session-2.16.0-6.el5
gnome-desktop-devel-2.16.0-1.fc6
wireshark-gnome-0.99.5-1.el5
gnome-menus-2.16.0-2.fc6
libgnomecanvas-devel-2.14.0-4.1
libgnomeui-2.16.0-5.el5
gnome-utils-2.16.0-3.el5
gnome-python2-desktop-2.16.0-1.fc6
gnome-python2-gtkhtml2-2.14.2-4.fc6
libgnomeprintui22-devel-2.12.1-6
gnome-speech-0.4.5-1.fc6
gnome-icon-theme-2.16.0.1-4.el5
gnome-python2-applet-2.16.0-1.fc6
gnome-vfs2-devel-2.16.2-4.el5
libgnomeprint22-devel-2.12.1-9.el5
gnome-pilot-2.0.13-16
gnome-vfs2-2.16.2-4.el5
libgnome-2.16.0-6.el5
libgnomeprintui22-2.12.1-6
gnome-python2-canvas-2.16.0-1.fc6
rhn-setup-gnome-0.4.13-1.el5
gnome-python2-bonobo-2.16.0-1.fc6
libgnomeui-devel-2.16.0-5.el5
libgnomeui-devel-2.16.0-5.el5
gnome-speech-0.4.5-1.fc6
libgnomecanvas-2.14.0-4.1
gnome-mag-0.13.1-1.fc6
gnome-keyring-devel-0.6.0-1.fc6
NetworkManager-gnome-0.6.4-6.el5
gnome-python2-gnomevfs-2.16.0-1.fc6
libgnomeprintui22-devel-2.12.1-6
libgnomecups-0.2.2-8
gnome-themes-2.16.0-1.fc6
gnome-doc-utils-0.8.0-2.fc6
gnome-desktop-2.16.0-1.fc6
gnome-system-monitor-2.16.0-3.el5
gnome-python2-gconf-2.16.0-1.fc6
gnome-applets-2.16.0.1-19.el5
gnome-vfs2-devel-2.16.2-4.el5
openoffice.org-gnome-integration-2.0.4-5
libgnomecanvas-2.14.0-4.1
gnome-mount-0.5-3.el5
gnome-power-manager-2.16.0-7.el5
gtk2-2.10.4-16.el5
gtk+-1.2.10-56.el5
gtk2-engines-2.8.0-3.el5
gtk-doc-1.7-1.fc6
pygtk2-devel-2.10.1-8.el5
gtk2-devel-2.10.4-16.el5
pygtk2-2.10.1-8.el5
pygtk2-libglade-2.10.1-8.el5
pygtk2-devel-2.10.1-8.el5
gtkspell-2.0.11-2.1
libswt3-gtk2-3.2.1-18.el5
gtk2-2.10.4-16.el5
gtkhtml3-3.12.0-1.fc6
gnome-python2-gtksourceview-2.16.0-1.fc6
authconfig-gtk-5.3.12-2.el5
gnome-python2-gtkhtml2-2.14.2-4.fc6
gtk2-engines-2.8.0-3.el5
gtk2-devel-2.10.4-16.el5
gtk+-devel-1.2.10-56.el5
usermode-gtk-1.88-3.el5
pygtk2-codegen-2.10.1-8.el5
libgtk-java-2.8.7-3.el5
gtksourceview-1.8.0-1.fc6
gtkhtml2-2.11.0-3
gtkhtml3-3.12.0-1.fc6


How reproducible:
Every time

Steps to Reproduce:
1. Highlight text in say gnome-terminal.
2. Close all instances of gnome-terminal.
3. Try to paste selected text using middle mouse button into a new application.
  
Actual results:
Nothing is pasted.

Expected results:
Perviously selected text should have been pasted.
Comment 1 Ray Strode [halfline] 2007-10-22 16:28:28 EDT
what's the output of 

ps -ef |grep settings

?

Comment 2 Andrew Case 2007-10-22 16:35:49 EDT
acase     8758     1  0 Oct18 ?        00:00:09 /usr/libexec/gnome-settings-daemon
acase    31951  9074  0 16:35 pts/11   00:00:00 grep settings
Comment 3 Ray Strode [halfline] 2007-10-22 16:43:08 EDT
can you strace -s512 -p 8758 

and report the output?
Comment 4 Andrew Case 2007-10-22 17:05:09 EDT
Created attachment 234541 [details]
strace -s512 -p 8758

Strace attached.  This trace was occuring while I had gedit open before I
started the strace,  then ran the trace, typed some words into gedit and
highlighted them, then closed gedit, tried to post into firefox, then stopped
the trace.
Comment 5 ritz 2007-10-22 17:32:35 EDT
Hello

  On _personal_ basis, and no. i am not an engineer. Is this not an expected
behavior of X, and the reason behind development of klipper/glipper ?
Comment 6 Andrew Case 2007-10-25 12:58:28 EDT
I guess you're right.  I thought this functionality was in RHEL4 but it doesn't
appear to have been.  It doesn't look like RH includes glipper for RHEL5 though.
Comment 7 ritz 2007-10-26 06:42:46 EDT
gnome does not have a "official" clipboard manager as of now. 
Best bet i can think of  is for EPEL (
http://fedoraproject.org/wiki/EPEL/FAQ#contact ). 

Note You need to log in before you can comment on or make changes to this bug.