This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 345931 - sparse breakage triggered by rcu_read_lock() lockdep annotations
sparse breakage triggered by rcu_read_lock() lockdep annotations
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sparse (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 16:18 EDT by Jeff Layton
Modified: 2014-06-18 03:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: 0.4-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-05 10:06:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch -- fix breakage due to rcu_read_lock lockdep annotation (1.64 KB, patch)
2007-10-22 16:18 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2007-10-22 16:18:22 EDT
When trying to build latest rawhide kernels on x86_64, sparse throws an error
and the build fails. It usually crashes while building
./arch/x86/ia32/ia32_binfmt.c:

    sparse: flow.c:805: rewrite_parent_branch: Assertion `changed' failed.

There is a apparently an upstream patch to the latest sparse that fixes this. I
built a sparse package with the 2007-10-22 nightly tarball and it seems to work.

This is the only link to the upstream discussion on this that I could find:

    http://www.gossamer-threads.com/lists/linux/kernel/833258

Attaching patch below...
Comment 1 Jeff Layton 2007-10-22 16:18:23 EDT
Created attachment 234401 [details]
patch -- fix breakage due to rcu_read_lock lockdep annotation
Comment 2 Fedora Update System 2007-11-05 10:06:06 EST
sparse-0.4-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2007-11-06 11:01:00 EST
sparse-0.4-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.