Bug 34595 - xemacs-21.1.14-2 seems to have broken vm key bindings
xemacs-21.1.14-2 seems to have broken vm key bindings
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xemacs (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-03 20:32 EDT by Ronald Cole
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-23 16:07:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Cole 2001-04-03 20:32:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


Under xemacs-21.1.12-3, running vm (M-x vm) and composing an email (m), C-c
C-w runs the command "mail-signature".  This is as expected.  It results in
the ~/.signature file being appended at the end of the buffer with a "\n--
" separator.

Applying the errata xemacs-21.1.14-2, starting vm and composing an email,
C-c C-w runs the command "insert-signature", which is wrong.  It causes the
~/.signature file to be inserted at point instead of at the end of the
buffer and doesn't insert the "\n-- " separator.

Reproducible: Always
Steps to Reproduce:
1. xemacs
2. M-x vm
3. m
4. type some email in the body and move the point to the middle of the text
5. C-c C-w
	

Actual Results:  ~/.signature was inserted at point with no separator.

Expected Results:  ~/.signature should be appended to the end of the
buffer, separated by "\n-- ".
Comment 1 Trond Eivind Glomsrxd 2001-04-04 11:54:23 EDT
That sounds more like "changed" than "a bug". If you're not happy with the new
binding, I suggest you modify this in your local .emacs
Comment 2 Ronald Cole 2001-04-04 16:57:38 EDT
But why would RedHat fiddle with the XEmacs distribution?  And why would RedHat
not document such a change?
Comment 3 Trond Eivind Glomsrxd 2001-04-04 17:03:04 EDT
We didn't change this, we just included the newest lisp bundle which it seems
upgraded this subpackage, the new subpackaging having this new keybinding.

We don't document the changes at the package level unless we do it ourselves.
Comment 4 Ronald Cole 2001-04-04 18:28:11 EDT
No, the vm-6.75 in the errata does not have that "new keybinding".  Look at the
elisp yourself.
Perhaps another package in the bundle you've included is clobbering that key
binding, since your suggestion of setting it myself in my .emacs:

(require 'sendmail)
(define-key mail-mode-map "\C-c\C-w" 'mail-signature)

didn't work around your "feature".  I still consider this a bug.
Comment 5 Ronald Cole 2001-04-17 18:00:53 EDT
Ok, I found the problem.  You *did* fiddle with the XEmacs distribution by
introducing the package "Wanderlust".  I note that "Wanderlust" isn't listed in
the file /usr/share/xemacs-21.1.14/etc/package-index.LATEST.pgp.

The file /usr/lib/xemacs/xemacs-packages/lisp/site-start.d/wl-init.el contains
the line (load "mime-setup"), which it gets from the "tm" package. 
Unfortunately, "tm" and "vm" don't get along here.  Also, unfortunate is that
RedHat didn't heed the Wanderlust MIME module suggestions on their web site
<http://www.gohome.org/wl/>, where they say: "Before installing Wanderlust,
please install either of the following MIME modules. SEMI is recommended because
it's more functional."

I haven't tested installing SEMI, but removing wl-init.el from site-start.d
solves the problem.  I suggest removing Wanderlust from the .rpm until such time
as it's listed as an offical XEmacs package in package-index.LATEST.pgp.
Comment 6 Trond Eivind Glomsrxd 2001-04-17 18:13:05 EDT
Semi is included in the package as well. Nakai, you added wl - please fix it not
to disrupt non-Japanese packages.
Comment 7 Ronald Cole 2001-04-17 18:39:20 EDT
No, semi is not included:

$ ls -l xemacs*
-rw-r--r--    2 root     root     20247307 Feb  7 13:28
xemacs-21.1.14-2.7.i386.rpm
-rw-r--r--    2 root     root      8629561 Feb  7 13:29
xemacs-el-21.1.14-2.7.i386.rpm
-rw-r--r--    2 root     root      1526587 Feb  7 13:31
xemacs-info-21.1.14-2.7.i386.rpm
$ for i in xemacs*; do rpm -qpl $i | grep -i semi; done
$
Comment 8 Trond Eivind Glomsrxd 2001-04-18 13:56:38 EDT
Sorry for that misunderstanding - it's part of the xemacs packages for 7.1, not
the errata packages. It was merged after the errata release
Comment 9 Ronald Cole 2001-05-10 19:26:12 EDT
Ok, I've tried 7.1.  Yes, it includes SEMI, but semi-init.el also loads
mime-setup from the tm package.  So removing both semi-init.el and wl-init.el
fixed the problem in 7.1 for me.
Comment 10 Jens Petersen 2002-11-11 08:11:00 EST
semi is now included in the separate wl package.

Note You need to log in before you can comment on or make changes to this bug.