Bug 346021 - nv (nvidia) driver fails to find modeline in common with display F8T3
nv (nvidia) driver fails to find modeline in common with display F8T3
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-22 16:57 EDT by Todd Denniston
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-25 18:20:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log from F8T3 (50.23 KB, text/plain)
2007-10-22 16:57 EDT, Todd Denniston
no flags Details
lspci on F8T3 (1.56 KB, text/plain)
2007-10-22 16:58 EDT, Todd Denniston
no flags Details
xorg.conf on F8T3 (642 bytes, text/plain)
2007-10-22 16:58 EDT, Todd Denniston
no flags Details
Xorg.0.log from F7 (49.68 KB, text/plain)
2007-10-22 16:59 EDT, Todd Denniston
no flags Details
lspci on F7 (1.53 KB, text/plain)
2007-10-22 16:59 EDT, Todd Denniston
no flags Details
xorg.conf on F7 (564 bytes, text/plain)
2007-10-22 17:00 EDT, Todd Denniston
no flags Details
xdpyinfo from the working Fedora 7 install (4.25 KB, text/plain)
2007-10-22 18:15 EDT, Todd Denniston
no flags Details
Xorg.0.log from F8T3 with both cables attached and xorg working (50.24 KB, text/plain)
2007-10-25 17:34 EDT, Todd Denniston
no flags Details
xdpyinfo from F8T3 with both cables attached and xorg working (4.21 KB, text/plain)
2007-10-25 17:35 EDT, Todd Denniston
no flags Details

  None (edit)
Description Todd Denniston 2007-10-22 16:57:20 EDT
Description of problem:
When installing Fedora 8 Test 3 Fedora-7.92-i386-DVD.iso, by booting with
Fedora-7.92-i386-rescuecd.iso and accessing the DVD iso on a USB hard drive, the
graphical install failed to work because the video only showed random 'bar's on
the screen.

After installing in text mode, running startx results in the same random 'bar's
on the screen. attempts were made, with system-config-display, find a
configuration which worked, but they all resulted in the same output.

I assume that the inability to switch to a usable virtual console (all were
garbled) was due to the fact that xorg attempted to fall back to frame buffer
which is not configured in a Fedora 8 Test 3 system.

Version-Release number of selected component (if applicable):
All components as built and delivered in the Fedora-7.92-i386-DVD.iso, no upgrades.

How reproducible:
Always.

Steps to Reproduce:
1. install  F8T3 in text mode on a system with an nVidia Corporation G71GL
[Quadro FX 3500] [10de:029d] (rev a1) (prog-if 00 [VGA])
2. run `startx&sleep 60;reboot
3. see random bars
4. after reboot, look at /var/log/Xorg.0.log see that xorg could not find a
modeline to match between card and screen.
  
Actual results:
random bars on the screen.

Expected results:
F8T3 X session.

Additional info:
I have two of these machines, one of which is running F7, and one with F8T3.
Under F8T3 Xorg.0.log looks to me as though it can not find a good modeline in
common between the card and display, and then attempts to fall back to frame buffer.
Under F7 the Xorg.0.log looks to me as though it both finds some good modelines
and still falls back to frame buffer, but it works.

Attaching files from both machines so they can be compared.
1) Xorg.0.log from F8T3 
2) lspci -vvv -nn of the device from an F8T3 install
3) xorg.conf from F8T3
4) Xorg.0.log from F7 
5) lspci -vvv -nn of the device from an F7 install
6) xorg.conf from F7
Comment 1 Todd Denniston 2007-10-22 16:57:20 EDT
Created attachment 234471 [details]
Xorg.0.log from F8T3
Comment 2 Todd Denniston 2007-10-22 16:58:19 EDT
Created attachment 234481 [details]
lspci on F8T3
Comment 3 Todd Denniston 2007-10-22 16:58:48 EDT
Created attachment 234491 [details]
xorg.conf on F8T3
Comment 4 Todd Denniston 2007-10-22 16:59:21 EDT
Created attachment 234501 [details]
Xorg.0.log from F7
Comment 5 Todd Denniston 2007-10-22 16:59:50 EDT
Created attachment 234521 [details]
lspci on F7
Comment 6 Todd Denniston 2007-10-22 17:00:22 EDT
Created attachment 234531 [details]
xorg.conf on F7
Comment 7 Todd Denniston 2007-10-22 18:15:02 EDT
Created attachment 234581 [details]
xdpyinfo from the working Fedora 7 install

I was thinking that the output of xdpyinfo might help in figuring out which of
the 1280x1024 modlines was being used under FC7.
Comment 8 Adam Jackson 2007-10-23 09:37:47 EDT
It looks like you have two displays attached.  Do you?  The nv driver doesn't
handle that well.
Comment 9 Todd Denniston 2007-10-25 17:26:47 EDT
(In reply to comment #8)
> It looks like you have two displays attached.  Do you?  The nv driver doesn't
> handle that well.

No, just one monitor on each of the computers... 

But when I went to get the model of the computer and monitor [Dell precision 390
with a Dell 1907FPf monitor], I noticed that when the person assembled the units
they attached both the VGA cable with a DVI converter and the DVI cable(yes this
seems strange to me too, I just had not noticed till now).  However on the
working unit the VGA cable was in the left hand port (as you look at the back of
the tower), and the DVI in the right hand port.  I Swapped the cables on the non
working unit and xorg then worked.

Also if I just plugged one cable in to the CPU system, in either port, and power
cycled the box xorg would work, So I would suspect most normally installed
machines will work.

I will attach an Xorg.0.log and xdpyinfo from the F8T3 machine from when it
worked with both cables hooked up.

The only reason at this point that I can see for keeping this open is that I
would think that if it could work with the cables plugged into the two
equivalent ports one way, then swapping VGA and DVI port assignments should not
have been hard for X.  
Definitely not a blocker for Fedora 8.
Comment 10 Todd Denniston 2007-10-25 17:34:57 EDT
Created attachment 238091 [details]
Xorg.0.log from F8T3 with both cables attached and xorg working
Comment 11 Todd Denniston 2007-10-25 17:35:59 EDT
Created attachment 238101 [details]
xdpyinfo from F8T3 with both cables attached and xorg working
Comment 12 Dave Airlie 2007-10-25 18:20:49 EDT
this is pretty much can't fix as we don't have any information from nvidia on
how their cards work. good to know it was just multiple cables.

Note You need to log in before you can comment on or make changes to this bug.