Bug 34632 - pcmcia eth0 gone after resume from suspend
pcmcia eth0 gone after resume from suspend
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 03:59 EDT by Gerald Teschl
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-26 12:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2001-04-04 03:59:25 EDT
(qa0401)
If I suspend my laptop (beta hw list #12) and resume, my pcmcia network
interface eth0 is gone. Card will work again if I say "service pcmcia
restart"
on the command line.

If I use "cardclt suspend/resume" from the command line everything works
fine.
Also had no problems under RH7.0 (without PCMCIARESTART="yes"). I tried to
use

PCMCIARESTART="yes"
PCMCIABIOSBUG="yes"
PCMCIAWAIT="no"

in /etc/sysconfig/apmd but it makes no difference. 


For the records:
------------------------------------
[root@soliton /root]# cat /etc/sysconfig/pcmcia
PCMCIA=yes
#PCIC=i82365
PCIC=yenta_socket
PCIC_OPTS=
CORE_OPTS=
CARDMGR_OPTS="-q -f"
[root@soliton /root]# cardctl ident
Socket 0:
  product info: "TAMARACK", "Ethernet", "A", "004743118001"
  function: 6 (network)
--------------------------------------
Comment 1 Matthew Miller 2001-04-06 09:42:04 EDT
Same on my Toshiba Libretto 50CT with all three network cards I tried -- two
Linksys ones and a Cisco Aeronet card. With the linksys cards, popping them out
and putting them back in again causes them to be recognized. (With the cisco
one, that causes a kernel panic -- that's probably a separate issue, though -- I
need to investigate that further.)
Comment 2 Gerald Teschl 2001-04-27 13:33:23 EDT
Still present in 7.1. It even suffices to say "ifup eth0" to bring the if up.
However, the
NET_RESTART="yes" option doesn't seem to help. Pretty annoying!
Comment 3 Bernhard Rosenkraenzer 2001-05-12 15:20:48 EDT
Fixed in -31
Comment 4 Gerald Teschl 2001-05-15 04:13:19 EDT
Nope. Not fixed. In fact, now it is even worse since I cannot use ifup anymore

[root@soliton gerald]# ifup eth0
SIOCSIFFLAGS: No such device
SIOCADDRT: Network is down
SIOCADDRT: Network is unreachable

and I have to do a full "service pcmcia restart".
Comment 5 Gerald Teschl 2001-05-15 04:32:02 EDT
Please ignor the above "ifup" problem, it works now.

I just did some further investigations and located the problem:

I once suggested a clean solution for the "failed" message when a pcmcia network
interface
is started before pcmcia is started (which is the case during boot). However,
redhat turned my
patch down since it is "much better" to set ONBOOT="no" for such devices. But if
you
do this, the command "service network start" in the apm script has no effect on
this interface
and it is not brought up. So much about "quick and easy" solutions.

So if I set ONBOOT="yes" everything is fine again.
Comment 6 Gerald Teschl 2001-05-15 04:38:53 EDT
See bug #22979
Comment 7 Gerald Teschl 2001-05-16 12:27:23 EDT
Unfortunately the

[root@soliton gerald]# ifup eth0
 SIOCSIFFLAGS: No such device
 SIOCADDRT: Network is down
 SIOCADDRT: Network is unreachable

problem is still here. However, it only happens sometimes.
If I do a "cardctl reset 0" it does not help. But if I say
"cardctl eject 0; cardctl insert 0" it works.

Not sure if this is an apmd or pcmcia problem. 
Comment 8 Gerald Teschl 2001-06-19 14:30:25 EDT
I just did some further investigations and observed that the card is "ejected"
correctly
by the apm script upon suspend. However, upon resume the card is already active
when the apm scripts "inserts" the card again. As a temorary work around I use

--- apmscript.orig   Sat May 12 19:19:09 2001
+++ apmscript   Sat Jun 16 09:13:34 2001
@@ -217,6 +217,7 @@
 
        if [ "$PCMCIARESTART" = "yes" ] ; then
                if [ "$PCMCIABIOSBUG" = "yes" ]; then
+                       /sbin/cardctl eject
                        /sbin/cardctl insert
                else
                        /sbin/cardctl resume
Comment 9 Gerald Teschl 2001-08-06 16:10:52 EDT
Still broken in beta3
Comment 10 Bernhard Rosenkraenzer 2002-02-26 12:26:21 EST
Please check if this is still a problem in 3.0.2-6 - my PCMCIA cards (and chipsets) are 
apparnetly much more tolerant to being inserted a couple of times in a row than yours.
Comment 11 Gerald Teschl 2002-02-28 11:21:14 EST
Seems to work in 7.2. Sometimes the interface does not come up after
wakeup from sleep

Note You need to log in before you can comment on or make changes to this bug.