Bug 346531 - Port ant to use NSS library for cryptography
Port ant to use NSS library for cryptography
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Permaine Cheung
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:16 EDT by Peter Vrabec
Modified: 2011-06-10 03:46 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-10 03:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:16:29 EDT
ant should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Alexander Kurtakov 2011-06-10 03:46:57 EDT
This bug should really be closed for several reasons:
* Noone is working on it. 
* NSS requires jni use which is a PITA in the Java land. 
* Such a solution won't be accepted upstream.

Java is quite different from the rest of the world in this area. Please feel free to reopen if someone wants to work on it.

Note You need to log in before you can comment on or make changes to this bug.