Bug 34671 - AIC7xxx driver causes install to kernel panic
AIC7xxx driver causes install to kernel panic
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-04 07:56 EDT by Need Real Name
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-04-04 07:56:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


I got the latest driver disk image from both 
http://people.redhat.com/dledford/aic7xxx.html and 
http://people.freebsd.org/~gibbs/linux/ (same result with both). Now when 
I load up the installer and put in my driver disk it loads fine. But when 
I actually load the AIC7xxx driver, the install kernel panics. 

Reproducible: Always
Steps to Reproduce:
1. Start Install
2. Load driver disk created by dd.img on 
http://people.redhat.com/dledford/aic7xxx.html
3. Load AIC7xxx SCSI driver
	

Actual Results:  Kernel Panic

Expected Results:  Loads driver and continues install

I had an older version (sorry, don't know version number) that worked 
fine. But I can't get the dd.img for that version of the driver.
Comment 1 Michael Fulbright 2001-04-04 10:43:36 EDT
Any ideas doug?
Comment 2 Need Real Name 2001-04-04 11:08:43 EDT
Getting a copy of the actual screen dump. Will take a while.. no cut and paste.
Comment 3 Need Real Name 2001-04-04 11:38:21 EDT
What's on my screen:

Current->tss.cr3 = 00101000, %cr3 = 00101000
*pde = 00000000
Oops: 0000
CPU:     0
EIP:     0010:[<c0107e97>]
EEFLAGS: 00010086
eax: 00000000   ebx: 00000000   ecx: 00000000   edx: dffee000
esi: c0100176   edi: c0218000   ebp: e0800000   esp: c0217e64
ds: 0018   es: 0018   ss: 0081
Process swapper (pid: 0, process nr: 0, stackpage=c021700)
Stack: c0216000 00000003 00000082 20000000 e1000000 c0107ef5 c0217ec4 c01c7858
       c01c8dae 00000000 00000000 c010d173 c01c8dae c0217ec4 00000000 c0216000
       00000000 df47e000 00000003 c009ee45 00000003 c0107b8d c0217ec4 00000000
Call Trace: [<e1000000>] [<c0107ef5>] [<c01c7858>] [<c01c8dae>] [<c010d173>] 
[<c01c8dae>] [<c0107b8d>]
            [<c01a0018>] [<c01a08ba>] [<c01a208d>] [<c01a2060>] [<c0110100>] 
[<c0116f79>] [<c0108b6a>] [<c0108824>]
            [<c01062e3>] [<c0106332>] [<c0106000>] [<c0106370>] [<c0107a88>] 
[<c0106000>] [<c0106077>] [<c010600>]
            [<c0100176>]
Code: 0f b6 0c 03 89 4c 24 14 51 68 50 78 1c c0 e8 18 a2 00 00 83
Aiee, killing interrupt handler
kernel panic: Attmpted to kill the idle task!
In swapper task - not syncing
Comment 4 Need Real Name 2001-04-05 13:24:48 EDT
The SCSI bios is an Adaptec AIC-7895. Onboard a Tyan Thunder 100.

It has all the lates BIOS upgrades.

Please get back to me on the ASAP.
Comment 5 Doug Ledford 2001-04-06 10:08:39 EDT
Can you try using the driver update disk image from my web site on another
machine and see if it works?  After parsing the oops output above, things look a
little fishy, like there might be a hardware issue at play (bad memory chip,
something like that).  Testing to see if this is localised to one machine of if
that update disk won't work on any of your machines would be helpful.
Comment 6 Need Real Name 2001-04-06 10:23:15 EDT
It doesn't work in any of the machines I have tried it in.
Comment 7 Matt Wilson 2001-08-02 14:22:50 EDT
kernel problem; not installer.
Comment 8 Doug Ledford 2001-08-21 13:55:36 EDT
Since your driver disk fails on all machines, I would suspect the problem is a
bad disk or a bad download of the image.  Please try making a new disk entirely
and see if that helps.
Comment 9 Bugzilla owner 2004-09-30 11:38:57 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.