Bug 346711 - Port coreutils to use NSS library for cryptography
Port coreutils to use NSS library for cryptography
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:17 EDT by Peter Vrabec
Modified: 2010-03-16 08:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 08:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:17:12 EDT
coreutils should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Kamil Dudka 2008-08-27 07:48:28 EDT
This is (maybe incomplete) list of affected coreutils utilities:
  base64 - encoding/decoding
  md5sum, sha1sum, sha224sum, sha256sum, sha384sum, sha512sum - hash algorithms

Upstream has rejected porting this utilities to NSS at this time, because replacement of working hash algorithms are not very useful from upstream perspective.

I am also not sure if coreutils fundamental utilities (like md5sum) should be dependent on NSS library.
Comment 2 Ondrej Vasik 2010-03-16 08:36:26 EDT
Based on comment #1 closing WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.