Bug 346791 - Port dbus to use NSS library for cryptography
Port dbus to use NSS library for cryptography
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:17 EDT by Peter Vrabec
Modified: 2013-03-05 22:53 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 11:16:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:17:31 EDT
dbus should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 David Zeuthen 2007-10-23 11:16:47 EDT
AFAIK, we don't use any non-trivial crypt in D-Bus right now

[davidz@oneill ~]$ ldd /lib/libdbus-1.so
        linux-gate.so.1 =>  (0x00110000)
        libcap.so.1 => /lib/libcap.so.1 (0x0088d000)
        libc.so.6 => /lib/libc.so.6 (0x00111000)
        /lib/ld-linux.so.2 (0xb7fb6000)

[davidz@oneill ~]$ ldd /bin/dbus-daemon 
        linux-gate.so.1 =>  (0x0012d000)
        libexpat.so.1 => /lib/libexpat.so.1 (0x0012e000)
        libselinux.so.1 => /lib/libselinux.so.1 (0x0014f000)
        libpthread.so.0 => /lib/libpthread.so.0 (0x0016a000)
        libaudit.so.0 => /lib/libaudit.so.0 (0x00183000)
        libcap.so.1 => /lib/libcap.so.1 (0x00198000)
        libc.so.6 => /lib/libc.so.6 (0x0019b000)
        libdl.so.2 => /lib/libdl.so.2 (0x002f4000)
        /lib/ld-linux.so.2 (0x00110000)

There's talk of adding TLS support, for the TCP/IP transport, I know that
Lennart needs that for Mango Lassi

 http://0pointer.de/blog/projects/mango-lassi.html

Anyway, closing as NOTABUG since we don't use non-trivial cryptography. Adding
the upstream author in case he wants to chip in. Feel free to reopen if I'm wrong.

Thanks,
David

Note You need to log in before you can comment on or make changes to this bug.