Bug 346831 - Port dovecot to use NSS library for cryptography
Port dovecot to use NSS library for cryptography
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:17 EDT by Peter Vrabec
Modified: 2013-10-16 11:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-29 07:23:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:17:40 EDT
dovecot should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 2 Fedora Admin XMLRPC Client 2009-05-21 09:17:01 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Cristian Ciupitu 2013-10-16 11:32:48 EDT
Shouldn't there be a reason for the WONTFIX like upstream doesn't have the resources to do the port or doesn't want to do it or whatever?
Comment 4 Ondrej Vasik 2013-10-16 11:43:00 EDT
I would say - lessons learned. Some packages did the port (e.g. elinks, openldap, links, curl and others), but usually it brought additional effort and issues caused by differences between openssl and nss ... meanwhile, the reasons for the port got less important, thus the priority for the port was lowered. 
In this case, Michal decided it is not worth of investing time. If you want to propose it to dovecot upstream, feel free to do so.

Note You need to log in before you can comment on or make changes to this bug.