Bug 3470 - Odd output from "whereis"
Summary: Odd output from "whereis"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-15 06:09 UTC by Edward Kuns
Modified: 2015-01-07 23:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-29 19:09:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Kuns 1999-06-15 06:09:23 UTC
I have /opt symlinked to /usr/opt.  Since upgrading to Red
Hat 6.0, the 'whereis' command seemingly looks in
"/opt/../bin" as well as "/usr/bin":


kilroy> whereis whereis
whereis: /usr/bin/whereis /opt/../bin/whereis
/usr/man/man1/whereis.1

If I "PATH=/bin:/usr/bin" I get the same output above, so
this isn't anything in my PATH variable.

Comment 1 Jeff Johnson 1999-06-15 11:44:59 UTC
A "strings /bin/whereis" indicates that whereis looks in /opt/*/bin.
The ".." should be ignored.


Note You need to log in before you can comment on or make changes to this bug.