Bug 347021 - Port gnome-games to use NSS library for cryptography
Port gnome-games to use NSS library for cryptography
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libggz (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:18 EDT by Peter Vrabec
Modified: 2010-01-28 11:53 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-28 11:53:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:18:26 EDT
gnome-games should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Andreas Røsdal 2007-10-23 12:03:36 EDT
This has been reported upstream http://bugzilla.gnome.org/show_bug.cgi?id=489457
Comment 2 Andreas Røsdal 2007-11-17 18:31:22 EST
Upstream status: 

"The NSS backend to libggz was improved a bit. While it's still not working for
some reason, the cause is likely just a missing function call somewhere.
Therefore, the patch has been merged into trunk and can be tested there
(--with-tls=NSS)."
Comment 3 Christopher Aillon 2008-01-03 11:16:29 EST
This really should go to libggz, as that's where the changes need to happen. 
The changeset to make it do so is
http://svn.ggzgamingzone.org/cgi-bin/trac.cgi/changeset/9362 .  In patch format,
it's
http://svn.ggzgamingzone.org/cgi-bin/trac.cgi/changeset/9362?format=diff&new=9362

Comment 4 Rex Dieter 2010-01-28 11:53:30 EST
* Thu Jan 28 2010 Rex Dieter <rdieter@fedoraproject.org> 0.99.5-7
- --with-tls=NSS (#347021)

better late than never.

Note You need to log in before you can comment on or make changes to this bug.