Bug 3471 - Odd pause after starting Netscape
Odd pause after starting Netscape
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: netscape (Show other bugs)
6.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-15 02:29 EDT by Edward Kuns
Modified: 2014-03-16 22:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-21 19:49:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 1999-06-15 02:29:26 EDT
Since upgrading to Red Hat 6.0, Netscape (4.51 and now 4.6)
pauses when reading my homepage.  That is, Netscape starts
up fine, displaying the "about:" page.  I click on the
"about:" page to force Netscape to go to my homepage which
is entirely local files on kilroy and there is a many second
pause that I didn't see on any Netscape version before 4.51
or on any version of Red Hat before 6.0.

This COULD be a nameserver issue as the pause seems shorter
when I an commected (via ppp) to the net than it does when I
am not connected.  I am not positive about this, however.
Does Netscape 4.51+ do any nameserver requests when fetching
the home page that cannot be satisfied by a caching-only
name server?  My homepage is specified as a "file:/...."
url.

When starting Netscape from certain Gnome programs (usually
from the Help menu of the Gnome program), Gnome times out
waiting for Netscape.  I don't know if this is related or
unrelated.  Trying this while connected to the net, I can't
seem to replicate this pause from Gnome programs.
Comment 1 Edward Kuns 1999-06-16 02:07:59 EDT
More information.  After I start netscape 4.6, if I am not connected
to the net, I eventually see the following message in my logs:

Jun 16 00:54:35 kilroy named[363]: ns_forw: sendto([192.33.4.12].53):
Network is unreachable

Doing an nslookup on that address gives me c.root-servers.net, so it
looks like Netscape is causing a name-server query even to do a local
"file:/" URL
Comment 2 Edward Kuns 1999-06-16 12:53:59 EDT
My final bit of information.  I reproduced the Netscape/Gnome
behavior.  If you run AisleRiot from the Gnome menus and click on Help
and click on the help for either kind of game, it will bring up
Netscape.  You'll see the Netscape window and a file:/ argument under
/usr/share.

Netscape won't display the image for 10-30 seconds, however, if you
are not connected to the Internet.  After a while, Gnome gives the
popup that says the following with the two buttons at the bottom:

No response to the SaveYourself command.
The program may be slow, stopped or broken.
You may wait for it to respond or remove it.

     Remove Program        Cancel
Comment 3 Bill Nottingham 1999-06-16 12:56:59 EDT
what if you go to (as a startup page, or wherever)

file:///usr/share/gnome/help/aisleriot/C/intro.html

instead of:

file:/usr/share/gnome/help/aisleriot/C/intro.html
Comment 4 Edward Kuns 1999-06-17 12:03:59 EDT
Same exact behavior including the "No response to the SaveYourself
command" complaint by gnome.  (I suppose it could be E complaining.)
Comment 5 Bill Nottingham 1999-06-17 15:28:59 EDT
What's the output of
a) 'ifconfig'
and
b) 'route -n'

when you are and aren't connected to the net?
Comment 6 Edward Kuns 1999-06-26 01:14:59 EDT
::::::::NOT CONNECTED TO THE NET::::::::::::

kilroy> ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:4B:14:BF:43
          inet addr:192.168.1.1  Bcast:192.168.1.255
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16988 errors:0 dropped:0 overruns:0 frame:0
          TX packets:62405 errors:0 dropped:0 overruns:0 carrier:30119
          collisions:21894 txqueuelen:100
          Interrupt:11 Base address:0xe800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:112393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

kilroy> route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref
Use Iface
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0
0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0
0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0
0 lo

::::::::CONNECTED TO THE NET:::::::::

kilroy> ifconfig
eth0      Link encap:Ethernet  HWaddr 00:10:4B:14:BF:43
          inet addr:192.168.1.1  Bcast:192.168.1.255
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16988 errors:0 dropped:0 overruns:0 frame:0
          TX packets:62407 errors:0 dropped:0 overruns:0 carrier:30121
          collisions:21894 txqueuelen:100
          Interrupt:11 Base address:0xe800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:112393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0

ppp0      Link encap:Point-to-Point Protocol
          inet addr:205.243.139.239  P-t-P:198.147.221.1
Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:552  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:10

kilroy> route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref
Use Iface
192.168.1.1     0.0.0.0         255.255.255.255 UH    0      0
0 eth0
198.147.221.1   0.0.0.0         255.255.255.255 UH    0      0
0 ppp0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0
0 eth0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0
0 lo
0.0.0.0         198.147.221.1   0.0.0.0         UG    0      0
0 ppp0
Comment 7 Bill Nottingham 1999-07-19 10:42:59 EDT
That looks OK (sorry about the long delay.)

Are you running a caching nameserver?
Comment 8 Edward Kuns 1999-07-29 12:52:59 EDT
Yes.  I have caching-namserver 6.0-2 installed.  When I "rpm -V" to
figure out what files I've changed, I have only changed
/etc/named.conf and /var/named/named.local.  Hmm, I didn't change the
latter but "rpm -V" gives S.5....T    -- my change to /etc/named.conf
was to add the lines:

	// logging interval -- 12 hours
	statistics-interval 720;

My resolv.conf has:

	search xnet.com
	nameserver 127.0.0.1
	nameserver <ISP nameserver #1>
	nameserver <ISP nameserver #2>

I keep intending to change this to only the first one, and make named
a forwarding nameserver.

None of this, however, changes the fact that when starting Netscape,
it generates some lookup request that times out.  Why do newer
versions of Netscape need to generate any name lookups for opening a
file:// URL?  Previous versions of Netscape did not do this.

I fully expect my named to time out when a name lookup request is made
and when I am not connected to my ISP (via ppp).  My complaint is that
Netscape is generating a nameserver request when it doesn't need to.

Admittedly, in addition to fixing Netscape, it would work to fix my
nameserver somehow to immediately reject all requests when I am not
connected to the Net.
Comment 9 Bill Nottingham 1999-08-21 19:48:59 EDT
Hmm... looking in both the netscape resources and the
binary itself, there doesn't seem to be a way to disable
this.

Perhaps try:
MOZILLA_NO_ASYNC_DNS=1 netscape

but I don't know if that will help.
If that doesn't I can't think of a good solution, because
the 'no route to host' timeout is the standard kernel
networking timeout.

Note You need to log in before you can comment on or make changes to this bug.