Bug 34711 - fix RPM creation on IRIX
Summary: fix RPM creation on IRIX
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-04-04 14:12 UTC by Joe Orton
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-04 14:13:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
First Fwrite fix (476 bytes, patch)
2001-04-04 14:12 UTC, Joe Orton
no flags Details | Diff
Second Fwrite fix (461 bytes, patch)
2001-04-04 14:13 UTC, Joe Orton
no flags Details | Diff

Description Joe Orton 2001-04-04 14:12:00 UTC
Courtesy of IRIX cc: fix checking of Fwrite() return codes.

"pack.c", line 509: warning(1183): pointless comparison of unsigned integer
          with zero
  	if (Fwrite(buf, sizeof(buf[0]), count, fd) < 0) {

This is particularly nasty since the compiler *optimizes out* the call to
Fwrite(), producing .rpms which aren't really all there.

Patches coming up...

Comment 1 Joe Orton 2001-04-04 14:12:35 UTC
Created attachment 14623 [details]
First Fwrite fix

Comment 2 Joe Orton 2001-04-04 14:13:22 UTC
Created attachment 14624 [details]
Second Fwrite fix

Comment 3 Jeff Johnson 2001-04-17 18:29:28 UTC
Fixed in CVS, will be in rpm-4.0.3-0.5. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.