Bug 347121 - Port gstreamer-plugins-base to use NSS library for cryptography
Port gstreamer-plugins-base to use NSS library for cryptography
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gstreamer-plugins-base (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:18 EDT by Peter Vrabec
Modified: 2008-06-02 16:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-02 16:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:18:50 EDT
gstreamer-plugins-base should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Bastien Nocera 2008-06-02 13:29:15 EDT
Which specific parts of gstreamer-plugins-base did you have in mind?
Comment 2 Tomas Mraz 2008-06-02 14:45:13 EDT
gst-libs/gst/cdda contains SHA-1 code, but this bug can be probably
closed-wontfix as using SHA-1 in cdda is not security relevant.
Comment 3 Bastien Nocera 2008-06-02 16:15:16 EDT
I filed http://bugzilla.gnome.org/show_bug.cgi?id=53631 about removing the
sha1.[ch] copy, and using glib's version instead.

Note You need to log in before you can comment on or make changes to this bug.