Bug 347141 - Port gwenhywfar to use NSS library for cryptography
Port gwenhywfar to use NSS library for cryptography
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gwenhywfar (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: CryptoConsolidation
  Show dependency treegraph
 
Reported: 2007-10-23 06:18 EDT by Peter Vrabec
Modified: 2014-03-16 23:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 13:30:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2007-10-23 06:18:55 EDT
gwenhywfar should be ported to use NSS library for cryptography.
See the tracking bug for details and links on how it could be done.
Comment 1 Bill Nottingham 2007-10-23 13:30:50 EDT
gwen uses:

a) CRL code
b) info and verify callbacks
c) bio

Ergo, don't think a straight port is really appropriate.
Comment 2 Bob Relyea 2007-10-23 16:36:12 EDT
These are pretty much the same things that libcurl, stunnel and a few others
use. nsscompatossl has support for info/verify and some bio callbacks. CRL's are
handled by ifdefing  out the SSL crl code since NSS support CRL's internally
automomatically.

bob

Note You need to log in before you can comment on or make changes to this bug.